atv2, 5.2 (6010.96).

I had to update to atv2, 5.2 (6010.96). do you guys have a jailbrake for this version or should i just update to 5.2.1 10B329a (6025), what do you recommend i do.

Thanks

I also want to know this as I have the exact same version on my box (never jailbroken before). I am obviously new to this and the list of alarming threads make me wonder if jailbreak is currently possible for this particular version.
Thanks!

I agree that you can use this method for a few firmware versions but I disagree in regards to any of the version 5's, except 5.0.2 (9B830) & 5.2 (10B144b)

 

*note those are firmware app version, not iOS references. If you are unsure check one of the many lists on line. If you are still confused use instead the version ID for example 10B144b, 9B830.

 

Agreed maybe the 1 i did on 5.1.1 already had blobs prior to me doing it but trust me it worked…

so i think its safe to say its needs to be a version that has had a working jailbreak for.

eg 4.3 4.4.4 5.0.2 5.2 etc

oops my fauly it was running 5.0.2 not 5.1.1 sorry guys

 

this method 100% works for 4.4.4 5.0.2 and 5.2 as for other fw versions im unsure as i dont have any devices on other firmware

Exactly, you would save yourself from being bombarded with pm’s and save others from wasting hours trying to do something impossible due to a “catch all” topic title.

 

Blobs or not, sn0wbreeze does not validate firmware 5.1.1 and tells you this.

It seems any of the tethered firmware 5 versions are invalid for this method, again check the website lists on firmwares and there status.

 

ill edit my post accoringly.

so do u have  a way to do 5.1.1 thats on atv with no blobs after ifaith grabs that blob?

Right I have had enough people Private messinging me follow the guide if your currently running an apple tv 2  with firmware  4.4.4  5.0.2 or 5.2 and you can jailbreak, as for other versions im not sure sn0w can do that,  as i dont have a device to test on that fw, but i would guess not as this method would appear to work only with an atv that has a fw on it, that has in the past had an untethered jailbreak released, like 4.4.4 5.0.2 and 5.2 but using the guide below i have jailbroken atv version 2s on 4.4.4 5.0.2 and lots 5.2 and this is after the release of 5.2.1
step 1,
get the ipsw that your apple tv is running from here and put it on the desktop
http://www.iclarified.com/entry/index.php?enid=970

stept 2,
get ifaith 1.5.5 from here.
http://ih8sn0w.com/
then run ifaith and when it asks if its an apple tv 2 say yes.
step 3,

close itunes (keep itunes closed)
follow the on screen instructions
it will pick up your blobs.
when u use ifaith to grab blobs close itunes.
if u encounter errors, like only recognized firmwares just try again thats normal or if it stops on the process just try again.
when the blobs are saved to the desktop go to step 4.
step 4,
get sn0wbreeze 2.9.13 from here
http://ih8sn0w.com/
run the latest version of sn0wbreeze and choose the ipsw for your apple tv that you downloaded from iclassified at the beginning that must match your apple tv firmware. (obviosly not 5.2.1 that cant be jailbroke)
then choose i faith mode
in ifaith mode get it to grab your blobs from your desktop that u saved earlier and let sn0w build your custom jailbroke firmware.

step 5,
once sn0w has built the firmware it will run ireb to put your atv in dfu again.

step 6,
open itunes whcich recognize you have an atv in recovery and opnly give you the restore option, this is where you hold the shift key on your pc/laptop and then direct itunes to the new custom built jailbroke firmware sn0w just built and it will put it on yourt apple tv. ( be carefull not to direct it to the iclassified standard version you used eraerlier cause thats not signed or jailbroke and itunes will thorw out error 3194)
Step 7,
you should connect your jailbroke apple tv 2 to the tv and u will have nito tv app where u can install xbmc but my preference would be to put atv flash black on it and update nito from the maintence app the atv flash will put on and then install xbmc from the maintence app also.

there you go guys Its simple just follow this guide
have fun :slight_smile:

Not aware if there is or ever was a tool to jailbreaks firmware 5.1.1 (10A831) untethered.

well there it is then if your on 5.1.1 u have to wait?

what about 5.1 or 5.0.1?

The firmwares which can be jailbroken, originally or with work-arounds, are just the same now as they were in the past. There are plenty of resources with the complete lists of jailbreakable firmwares.

mate where can u confirm if 5.0.0 or 5.0.1 or 5.1 can be done?

This site for example, just search. Everything anyone needs to know is contained with in, all new threads should be modded ASAP !!!

 

But then again Firecore needs the traffic while they are in limbo so I doubt that will happen :wink:

 

right so in that case the only 5 fw s that can be done using the ifaith sn0w build etc are 5.0.2 and 5.2?

is that correct?

Hi guys - still a bit new to JBing…have a few ATV2’s ready to JB, all running 5.2.  I followed the thread above using Snowbreeze and got a 1604 error after restoring in iTunes…I am running iTunes 10.7…any thoughts?  Geez this is frustrating…REALLY appreciate the help!

Here try this prolly needs a USB port change but the error is common N easy fixed dont panic
http://absinthejailbreak.com/forum/how-to-fix-itunes-error-16041600-1601-1602/

still getting the 1600 or 1604 errors every time I try and restore/install…tried about 10 different fixed.

 

Now when I take any atv and plug it into my tv I get the iTunes symbol and cord…how do I get the box back?

Mate u have to remove cydia host files.

Go into pc then open windows incon bottom left an type notepad
Open notepad as administrator u must open as administrator then open an navigate notepad to
Windows/system32/drivers/etc then change text Doc to all files in notepad then open hosts an delete everything in there that says stuff like 106.23.??? Apple.com all lines like that u must delete.

Then save

Then one notepad an reboot pc then open iTunes plug in Apple TV ab restore to the custom ipsw it will not give error.

Let me know how u get on?