ATV2 5.2.1 Issues

Hi,

I’m running a mac, iTunes 11 and I am having a very tough time jailbreaking my ATV2 with Seas0npass. Having just paid to renew my account and therefore access the new updates I know learned that I have basically paid to update a perfectly jailbroken ATV2 to one that is seemingly impossible to jailbreak. I have looked through countless forums on this site and others and still cannot find a solution.

I run seas0npass, everything downloads and what not fine. Seems to create the IPSW fine, but then when it comes to running the iTunes script, everything just stops. It sits at this screen for however long doing nothing. I have tried Option + Restore to manually select the IPSW and that seems to load through iTunes fine but when I plug the ATV into the TV, the jailbreaking has not worked. I have tried Boot Tethered after running this process to no avail. Am I doing something wrong? Is there a step I am missing? Seems to me at this point the only next step in troubleshooting is to downgrade iTunes to a past version and jailbreak that way. I know plenty of other people have encounted this problem but I have tried to follow other solutions but nothing has worked.

Seems everytime a new update is released, there is always immense frustration. Not sure why this is consistently a problem but it is. At this point I wished I had never touched it in the first place and REALLY wished I had not purchased the extension on my account. After every time I update I swear to myself that is the last time I’ll ever do it again but in the past it eventually did work after much frustration but that does not seem to be the case this time. If I ever get my ATV2 jailbroken again I swear it will the the last time, this time.

 

Help would be appreciated. Thanks in advance.

 

Signed,

A very frustrated, unhappy FireCore customer.

I had the same issue and couldn’t solve it until I downgraded my iTunes 11 down to 10.7. I ran the process according to the normal instructions and it worked with 10.7.

The process took forever, but I finall got it. Here’s a link to 10.7: http://support.apple.com/kb/DL1576