ATV2 5.0.1 (4224) Tethered Jailbreak with Seas0nPass 0.8.3.5820 - Problems

Hi all,

Just got a ATV2 running 5.0.1 (4224) and am trying to jailbreak it using the tethered method and Seas0nPass 0.8.3.5820 for Windows.

Everything has gone through fine but it appears as though the ATV2 simply isn’t jailbroken. I say this because when I try to install aTV Flash it shows an error saying it isn’t jailbroken. I have also tried to SSH into it but get “connection refused”.

Am I reading it right that this version of Seas0nPass should work with ATV2 5.0.1 (4224)??

Thanks.

Pete.

Seas0nPass 0.8.4 was just released, download the update and you should be good to go!

Thanks for the reply but 0.8.4.6306 doesn’t seem to be working as device isn’t getting jailbroken.

Just to check I am doing things right…

  1. Load Seas0nPass and select Boot Tethered

  2. Plug in USB and wait for flashing

  3. Plug in power and wait for quicker flashing

  4. Press Menu and Play on remote and wait for really mental flashing or 7 secs :slight_smile:

  5. Seas0nPass uploads some files and reports all OK

  6. Unplug USB and plug in HDMI before flashing stops

Even with all of the above I cannot install aTV Flash (Black). Am I doing something wrong or is this version of Seas0nPass just not working?

Thanks.

Where can I download the firmware file for ATV2 5.0.1? The latest version of SeasonPass (0.8.4) is still downloading and patching the older version (AppleTV2,1_5.0_9B206f_SP_Restore).

You will need to run the Create IPSW option first and restore this firmware to the Apple TV.

Full details on jailbreaking the Apple TV can be found here.

 

Any idea why SeasonPass on my system is still downloading and patching the old (previous) ATV2 firmware update instead of the most current one?

Their version numbers have never really made any sense, but build 9B206f is actually the latest version.

can’t find any wifi after update.

Worked like a charm for me. No issues what so ever.

So, I’m not seeing where the question was answered… the new version of Seas0nPass is downloading the older firmware from Apple, so it gave me an error message.

Which version of Seas0nPass are you using, and which file/version are you seeing it download?

Seas0nPass 0.8.4 and it seems to be downloading 5.0 (iOS 5.1 - 9B179b) instead of the new 5.0.1 (iOS 5.1.1 - 9B206f).

It will appear that way, but it should in fact be the latest version.

For whatever reason, the latest 5.0.1 (iOS 5.1.1) IPSW file for the ATV2 (downloaded straight from Apple) is named: AppleTV2,1_5.0_9B206f_Restore.ipsw

If in doubt, you can right-click the ‘Create IPSW’ button and it will allow you to choose the version you wish to use.

Got it. Thanks. I’ll keep trying.

ATV2 5.01 (4224) JB with 0.8.4.6.306. Every thing gone as the instaructions. JB successful with FC icon. But it Jbroken as tedthered. Need thedther boot each time I power off. I have gone through the procedure twice. Loaded the BlackFlash 1.5. But it is still in tedtherd.

wonder what I did wrong. Screen shown during: Downloading ATV2 1.5.0_9B206f_Restore.IPSW… Found DFU device… Uploading IBSSK66ap…Restoring ATV SW, Verifying ATVSW,

Restore ATV Firnmware. ATV has been restore to factory setting. When HDMI pluggin. It show Music note and usb cable cons. Put USB back and Perform tedtherBoot to get the display. Display show FC icon. I loaded the Blackflash OK Normal “Setting” return.

I am not sure what question you are actually asking or what problem you believe you have? From your description it sounds as if you have successfully done the tethered jailbreak. Installing the ATV Flash software will not stop it being tethered and thus needing a tethered boot any time you remove the power (or do a hard reset).

Thanks for respond. All alone I thought the version of SeasonPass will allow “Untedthered” JB. From various videos I watched. So I would expect mine would

work to be untedthered.

Please advise if thar is all I got for the version. So which version will give the unredthered. Firmware ? Seasonpass?

Again thanks.

hchiu

Whether SeasonPass jailbreaks are tethered or untethered depends on which version of firmware you are jailbreaking. For the latest 5.0.1 firmware the jailbreak is currently tethered. There have been twitter messages suggesting an untethered jailbreak for the 5.0.1 firmware is likely in the near future but no definitive ETA for it.

Ok, I’ve got a problem.

Thought I’d update the ATV2 and installed the new Apple TV software successfully after a restore.

I then jail broke it (Firecore  Version 0.8.4 said it was successful) , yet the script didn’t upload the software with the jailbreak.

Because, when I connect the ATV2 to the TV, it shows a picture of the USB cable and the iTunes logo. It’s the same picture that suggests that the device needs to connect to iTunes.

Never had this problem in the past. Do I just keep persisting and hope that it finally sticks?

Hope you can assist.

Justin

 

This is expected behaviour any time you remove the ATV2 power (or do a hard reset).

The current jailbreak is ‘tethered’ which means you have to connect the ATV2 to your PC/Mac Via USB as described in the second half of the document at http://support.firecore.com/entries/387605-jailbreaking-101-seas0npass. You must leave the power connected after completing the boot as you remove the USB and plug in the HDMI. This effectively means that during the boot process you have to have the ATV2 located where it is going to be used and bring the PC/Mac to it for the boot stage (which can be inconvenient).

There are indications that an untethered jailbreak for the latest firmware is likely in the next few weeks. The jailbreaking community are testing out a new jailbreak for the latest iOS that is expected to work on the ATV2 although until this is finally confirmed we cannot be certain it will work for the ATV2.