ATV2 4.4.4 stuck in dfu mode - possible error 1600 related

Hi Guys, i have my atv2 stuck in DFU mode,basically is flashing fast. i can’t find the software that kicks out the ios devices from the DFU mode, someone has a suggestion?

i also noticed that the ATVs having this issue or not flashing at all when connected to usb are the one giving me the error 1600


thank you

Connect your power cord, then connect the ATv to you computer via USB cable
Wait a few seconds until your ATv stops blinking

Worked for me, and hopefully would work for you as well

Mines similarly stuck.  Plugging in USB will not power the unit like it did before I started.  I plug in the power cable and the led just blinks.  If I try to do the DFU mode it just blinks fast and reboots.  If I take it over to the TV it just shows the picture “plug it into itunes”.  I’ve tried to restore and I get error 1611, among others but mostly that one.  I can’t even get it into DFU mode to do 90% of what most everyone claims will fix it.

Ok, I’m starting to think there is just a wide spread fact that micro usb cables are junk.  Tried a different cable and it restored.  Scratch my last.