ATV2 4.2 boot loop

Hi all, my Apple TV 2nd gen running ios 4.2.1 has gone into a boot loop this evening.  I’ve tried a few different fixes (reinstalling beigelist and nitotv packages, updating XBMC) but it’s stuck.  I don’t have SHSH blobs - has anyone else been experiencing this? Since 5.3 is a tethered jailbreak, am I screwed?

Since you still are running ios 4.2.1 you can save those blobs and then rejailbreak using those blobs.

I thought I couldn’t do that since Apple have long since stopped signing the 4.2.1 SHSH Blobs? I already tried this with Tinyumbrella with no success.  Should I be doing something different?

Short answer is you can still jailbreak to your present firmware version.

 

Your 4.2.1 firmware is already “signed” since it’s on your ATV. So you don’t need Apple to sign it again. All signing is is Apple adding the keys from your device to the firmware and then saying it’s OK to install it.

As far as saving your blobs, did you try it with seasonpass? (right click “create ipsw” and the choose save.

Yes. I also experienced this 2 days ago.

Firstly you’ll find that removing the atv’s internet connection will stop the bootloop.

Note that the atv can be on your home network, but cannot have an internet connection otherwise it will be stuck in the bootloop.

At my home I just switched off my cable modem and left my wifi router swtiched on to achieve this.

It is useful to have the atv on your home network because you can SSH to it, run commands, and back it up if you need to.

I am hoping that if you switch off the internet connection when you are, you will be able to save your blobs. I used iFaith to achieve this.

 

I also tried removing beigelist etc. Did not fix.

Then I tried re-installing my 4.2.1 firmware. Was not successful. Although I have my blobs saved etc I could not complete the process because iTunes threw an error every time I was restoring the signed firmware created by iFaith.

Then as a last ditch I installed iOS 5.3 i.e. I did a factory restore. Don’t try this if you don’t have your blobs saved!

The 5.3 factory restore worked. The aTV no longer boot loops when connected to the internet.

Then I downgraded back to 4.2.1 again using iFaith. No problems with iTunes this time, the process went without a glitch.

BUT … the bootloops are back.

I can’t help but wonder if apple has engineered this for people still on such an old version of the firmware?

Update - fixed for me :D

 

All I needed to do from here was re-do the jailbreak using greenpoison. I forgot that there was a 2nd step after jailbreaking on the laptop, you have to connect the atv back to the TV and follow a couple of steps (inject the payload) before the jailbreak is fully completed.

Once I had re-done the jailbreak I was able to edit hosts and then install xbmc manually.

See here http://forum.xbmc.org/showthread.php?tid=130296&pid=1480907#pid1480907 for a more complete description of the steps I took.

During this process I found that it looks like there are problems with nitotv. I ended up removing it.

Happy to go into more detail if it’s helpful.