aTV won't update software to latest version

I have aTV Flash installed, and noticed that I was not seeing the latest version of aTV software.  I checked “about” and it says I’m running version 4.3…yet when I click on “update software” in the aTV “settings” section it responds with “your software is up to date”.  The current software version for aTV is 5.2.  Any ideas why it won’t detect a software update is required?


Also, I went into “manage extras” and updated Couch Surfer and now when I go to the “Browser” menu and choose either “history”, “bookmarks” or “settings” the screen goes black for about 3 seconds and then jumps back to the iTunes MOVIES menu.  


HELP!   Should I restore my aTV and then re-install aTV Flash?

You cannot update a jailbroken ATV2 to a new version of firmware without going through the jailbreak process again for the new release of firmware. The jailbreak process deliberately suppresses the ability to update the firmware as doing so on a jailbroken system would fail and make the ATV2 unable to boot.  Redoing the jailbreak will wipe out ATV Flash so that also needs re-installing. You should be doing an update as ATV Flash latest release assumes release 4.4.4 or later of the firmware.

At this point there is no jailbreak for the 5.2 firmware although there are rumours of it not being far off.  The current version of SeasonPass supports an untethered jailbreak of the 5.0.2 firmware and a tethered jailbreak of the 5.1 firmware. 

If you are thinking of updating to either of these then you want to use the Backup option from within the Maintenance option.   This will back up the signatures for the current firmware in case you ever want to revert, and also back up your settings and saved metadata.   After re-jailbreaking and re-installing ATV Flash the corresponding Restore option can be used to get back setting without having to do them all again.

OK, so I connected my aTV to my mac (using micro USB) and did a restore to bring it to the latest version of aTV software (5.2).  Then I went through the process to jaibreak again using Seas0nPass.  Connected back to my HDTV and confirmed that everything worked, as I currently have the red FC logo instead of the normal “Settings” logo when running my aTV.  

Not sure what to do next.  How do I restore/add aTV Flash back to my aTV? 

Sounds as if you have completed the Jailbreak.   The next step is to run the ATV Flash installer on your Mac to install ATV Flash (via the network).

LOL…was really hoping for a few more details than that!    I know I need to run that, but where would I find that file?  It’s been a little over a year since I downloaded it.  Any help on what the installer file would be called so I can find it on my mac?  I’ve searched my mac for “Firecore”  and the only thing that comes up is a file called FC_Installer.log.  


OK…scratch the above.  I ran a new search of my Mac for “aTV” and found the original DMG from Nov. 2011  (atvflash-black_muptdnid133yurap.dmg).  I attempted top run it and was told it was out of date.  Help!  How do I get aTV flash back on my aTV?  (Please don’t tell me you’re going to require I pay for the software again.  I had aTV flash on my Apple TV as of 2 days ago, and nowhere in the documented process for jail braking, (nor in your support responses above) was I warned that if I attempted to restore my aTV to update the software and then re-install aTV Flash I would lose my previously purchased and have to buy your software again.

Please help!  (details…please)

Just like to point out that itimpi is not an official representative of FireCore (as mentioned in his signature line) but is just a user like yourself.

I would suggest that you send an email to the official FireCore support explaining your situation and see what they can do to help you resolve your problem.

Oh…I assumed this support page was staffed by FireCore.  Thanks for pointing that out.