ATV won't power with micro-usb

I’ve tried 2 cables, All tho I can get into DFU mode by plugging in power after usb cable… itunes errors out when trying to load the restore file season pass tries to open?

I’m having a similar problem. When prompted by seaOnPass I connect the USB cable to the desktop but the LED does not blink the APPLE TV. Why?

Because you have ATV3.

Did you unplug the power after entering DFU mode? You should.


After you plug in the micro usb briefly plug in the power cable and when the light starts to flash pull the power cable out. The continue with the jailbreak. Works guaranteed.

I had that issue several times and I’ve tried many different things and never found a clear way to make it work. Repeating the steps seems to be the only thing that managed to work over time.

One thing for sure, the cable seems to matter. I’ve bought a new one a month ago and the latest jailbreak was a lot easier than the previous ones.

  1. Run Seas0npass and start IPSW process

  2. When 1 concludes the soft prompts to connect the microUSB. Connect the microUSB and Porwer cords in that order. The led starts blinking.

  3. Press DOWN and MENU buttons simultaneously for six seconds- The led will start blinking very fast, then release the buttons and the led starts blinking more slowly.

  4. Unplug the Power cord but keep connected the misco USB. Wait about 10 seconds.

  5. press MENU and PLAY/pause buttons simultaneously for 7 seconds. The soft will detect the DFU mode and the jailbreak will start normally.

I’ve never had this problem. This is what I do and it works every time.

Leave your AV2 plugged in to the socket by the TV whilst you get SeasonPass to make up the patched iOS. Have your Micro USB cable handy.

As soon as SeasPass asks you to plug in your ATV2, disconnect the ATV2 from the mains and plug it into your computer via the Micro USB cable straight away.

Press the two buttons for seven seconds and SeasonPass does it’s magic.

If you get error messages with iTunes, think about uninstalling iTunes and then re-installing it - your library is left as it was. This worked for me when iTunes would not restore the ATV2 iOS.

I can now jail break and restore first time, every time. 8)

Good luck.