ATV w/ 2.1 and Patch 3.2 - can´t mount SMB-FS

Hi,

I patched one ATV 2.1 with the new Patch v3.2. After I set-up a mount-point to a SMB-NAS (worked with ATV4Win patched ATV) the finder restarts every time when I click to mount this mountpoint.

Please advise.

Thank you,

cm0815

I too am having this proplem!

Most annoying and most definitely something to do with the ATVFlash distro. No reports of this issue whatsoever over at NitoTV forums.

The whole thing is pretty much useless for what I wanted it for if I can’t mount anything on the network. I might need to get a refund if this doesn’t get fixed.

You can enable network mounts by following the steps at:

http://www.applecorellc.com/forum/viewtopic.php?f=10&t=67

But why do I have to cheat around? All our ATVs came with 2.x FW and these boxes worked with ATV4Windows Patchstick in the past and SMB-mount worked perfect. You still provide this option in the 3.2-version - is this a bug?

Please advise.
Cheers

cm0815

Thanks for pointing us to an article that is completely useless to us. My Apple TV was Take 2 factory installed. I have no idea where to get the recovery file that is mentioned and quite frankly I shouldn’t have to!

As the other poster has said, this works fine on other patchsticks so what is the problem?

If mounting drives is never gonna work then I would politely request your confirmation that I can have my money back please.

SMB mounts should work by performing steps 1-2 and 6-8. The recovery.dmg is required if you want to enabled AFP mounts.

Other distributors may have included these files in their versions, but distribution of these files technically is not legal.

Has anyone gotten this to work with a factory 2.02 version? I want to try this, but just wanted to know the success rate, and as it hard?
Thanks
Mo

Hi,

I followed the instructions and I´m now able to mount SMB-shares.

Thanks again,

cm0815

Did you get that error code all? I can’t figure out why its doing that!!

tonight i picked up a new aTV (latest firmware updated) and have installed the aTV Flash stuff. everything works EXCEPT being able to mount my network drive. and like most people here i continue to get the error code.

i followed the instructions and still have had no success. entering the information manually didn’t help, either, unless i am entering the information incorrectly? smb, IP address, mounted_disk_name… am i way off here?

cm0815, you got it working – can you tell us if you are on a mac or pc (does it even matter?) and did you do all the steps, or just 1-2 and 6-8?

i purchased aTV Flash mainly so i can watch movies outside of iTunes on a separate drive. if it doesn’t work as advertised, i’m also going to seek getting my money back by any means. i hope somebody can help with a little more detail here, there seems to be a big gap in the documentation and a lot of people are having the same problem. if there is anything you need to know from my side that would help troubleshoot, please let me know and i’ll be happy to oblige.

thanks.

Well said. That is all I want working too. Now, that is what is advertised on their page when purchasing this software. Does it work ? No. False advertising. I wanted my money back a long time ago, but keep getting the run around. So I will put in a dispute with my credit card company soon unless their is more information or other methods on getting this to work via applecorellc. I feel completely ripped off.

Waste of time and money.

Here is an example taken from another forum. It describes the setup in the nitoTV for SMB shares.

The setup:
I have an Airport Extreme Base Station (gigabit version) with the given name Sixshot. Attached to that AEBS is a USB hub with 6 external drives of varying sizes.

Disk Name------Contents

Rumble----------Music
Frenzy-----------TV Shows
Laserbeak-------Movies
Buzzsaw----------Stand Up Comedy
Ratbat------------Documents and backups
Ravage-----------Naughty things

For our example, we’ll refer to mounting the TV Shows in Frenzy. For additional illumination, the TV shows are in a subdirectory on the drive, called Vids (ex. e:\Vids-TV Shows-\ on a Windows system)

What I wanted, was to have nitoTV automatically mount the target drives and point directly to the given subfolders.

with the example discs and criteria above, the following works perfectly:

Mount Name: TV Shows
Mount Type: SMB
Mount Address: Sixshot.local
Requires Authentication: No
User Login:
Password:
Volume Path: Frenzy
Auto Mount: On
Use Custom Path: On
Custom Path: /Vids/-TV Shows-
Extra Arguments:

The drive mounts (most of the time) right at startup of the Apple TV and everything is ready to play.

Caveat 1: When I first started doing these mounts, I would get two selections in the nitoTV “Files” menu for evey mount that I made. One for the main drive (Frenzy in this case) and on for the custom path share (-TV Shows-). Since upgrading my AEBS firmware to 7.3.2, only the custom path share shows up. Fortunately, i prefer it that way.

Caveat 2: “Mount Name” is just a name for the mount listing in your “Network” menu selection. What you actually see in the “Files” menu is the drive name (volume path) unless you use the Custom Path selection, in which case you see the folder name at the end of the custom path

Final note: I originally bracketed my folder names in hyphens ("-TV Shows-" instead of “TV Shows” so that they would appear at the top of the “Files” menu, amidst the additional root drive shares that were being mounted when what i really wanted was the subdirectory path. (See Caveat 2)

If you are sharing a drive/folder from your Mac, you need to make sure you have it shared as SMB (unless you have AFP enabled, this is discussed in the AFP thread in the knowledgebase). You can set a share up as SMB through the System Preferences > Sharing > File Sharing > Options.

To be honest, the network share feature is not something that is advertised, mainly because it requires additional steps to setup, and it is not always as straightforward as it seems. Nevertheless, we want to help all our customers be fully satisfied with the aTV Flash. If you continue to have issues you can post them here, or send an email through our website to our support department.

http://www.applecorellc.com/contact.php

update: after messing around for many hours, i finally was able to get my network drive showing up in the aTV using smb. so that solves that problem. however, a few more have come up, which i’ll search the forum for - but for the sake of frustration i am going to list them here. if anyone has any advice or links, they’d be greatly appreciated.

  1. it is SLOW. opening a folder can take up to 30 seconds of hanging.
  2. playing a movie takes sometimes minutes before they start to play.
  3. when they do play, it stutters like crazy. unwatchable. and then IF the video shows up, it’s 50% the height it should be.

i spent another couple of hours messing around with export settings, HD vs SD, etc. the SD content streams quickly and nicely. The HD content croaks. I’ve done my research and my appleTV is on an N-only network. whether i try to watch a movie from my network drive or ftp one directly into the Movies folder, it is choppy and unwatchable.

However, i took the same movie and loaded it into my iTunes library, a blu-ray 720p rip with 5.1 audio. it plays SEAMLESSLY when it’s loaded through iTunes.

i am wondering why the same file plays so differently depending on whether it’s streaming from iTunes, when the software i purchased promises to function with the same level of quality while streaming from a network drive. any answers or suggestions are MORE than welcome.

In the NitoTV settings try changing the playback mode from MPLAYER to Quicktime.

This solved a lot of slowness and screen wiredness for me!

I’ve tried both mplayer and Quicktime, but DVD playback off of a network drive is not smooth. With either one I see a slight stutter approximately once a second. If I plug the disk into to the aTV USB port, the same VIDEO_TS folder plays smoothly. My aTV is connected to 100BASE-T Ethernet (i.e. wired, not wireless), and I’m playing the DVD off of a AFP mounted disk.

Is it possible to configure how much the aTV buffers before the movie/DVD starts playing? Seems like that might help.