atv not recognizing flash drive(s)- help?

Feb '09 I bought atvflash for Windows and installed on my atv 2.0 software. It took about 20 times of plugging in the flashdrive for the atv to recognize, but it finally worked.
I never upgraded atv software after that because I was worried that I would have a hard time upgrading the atvflash afterwards.
Well, the other day I figured it was time to upgrade the Atv to the latest version since Atvflash came out with 4.0.5 which included Open VPN.
I upgraded the Atv. I then downloaded atvflash 4.0.5 for windows. I formatted and used the same flashdrive that I used last year (I kept it on purpose for future upgrades since it had worked on my atv). I did everything per the instructions on the site. I have tried in excess now of 150 times since yesterday with the flashdrive that worked last year.
I have also bought 2 other flashdrives and neither one of them will the ATV recognize either.
All together I have sat there and attempted approximately 250 total times with no luck.
Maybe 10 times when the atv first starts powering the screen has turned Mauve colored for a second and a line ran through the middle of the screen, but then the apple logo goes on and nothing.
Suggestions? Again, a flash drive that I previous had success with is not being recognized. Any help would be greatly appreciated. I miss downloading my torrents and moving them to the ATV. I dont want to have to go back to burning DVD’s of them.

What type/size are the drives you’re attempting to use?

You may try reformatting your original flash drive using the steps described here:
http://wiki.atvflash.com/index.php?title=Reformat_Flash_Drive

1 and 2gb. I’ve formatted them 3-4 times each to try the process again and again. One of them was successful last year so I know that brand ca work.

just for giggles i went to patchstick.ca using the same thumb drive I used successfully with atvflash last year that has not worked this time. I created the patchstick there and the first time it worked and i was able to create a free version on the atv. I’ve spent 3 days and easily 500 attempts using the atvflash drive with no luck.
But here is the thing. I think atvflash is superior to patchstick.ca in what it offers as soon as the patch is done. I dont want patchstick and to have to pay again for what i already paid to atvflash. patchstick doesnt offer boxee beta or other things atvflash does.
My new question. Why has the atvflash download not created a working thumb drive after repeated efforts.
Also, now that i have patchstick.ca on my atv can I still try to install atvflash?
Would I have to remove patchstick.ca first? Would that entail a factory restore of the atv first?
Thanks.

Send us an email and we can assist you further.
http://www.atvflash.com/contact.php