aTV Flash is hanging every time

I must have done the flash drive business correctly (w/ a 512MB Cruzer) because when I plug it in the AppleTV and restart it starts the installation. But each time I’ve tried it (4X) it hangs at the same spot and doesn’t finish the install.

It’s real hard to read the screen, but the last line is something like:

 Interrupt: 10Base address :0x0000

I can reboot the AppleTV and the original OS is still there and it works normally.

Help!

Is the AppleTV hooked up via Etherent or wireless to your router? I’ve heard of problems when the AppleTV is hooked up wireless. If you can, try hooking it up via a wired Ethernet connection and try again. If you already have it hooked up via Ethernet, then I’m not sure what is going on. I’ll keep looking, but maybe someone else has an idea.

Thanks. It is on my wireless network.

The AppleTV is in the living room and the router is in the basement, so I’ll have no no TV to hook it to if I take it down there to do an Ethernet connect to the router. I guess I could just hook it up and let it run for 10 minutes and then bring it back up and hook back to the TV to see what happened.

I sure hope aTV Flash doesn’t require a static IP because I’m running DHCP and intend to keep it that way.

I’m having what appears to be the same problem. From the boot messages (somewhat hard to read as they’re cut off on the left edge of my screen) it very much looks like DHCP is failing and then the boot is hanging.

My appleTV is wirelessly connected, and working fine.

Is the install only supported over wired networks? If so, that seems like a pretty major detail to leave out of the docs.

Any help is much appreciated.

thanks,
Josh

Sounds like an incompatible flash drive. Take a look at: http://forum.atvflash.com/viewtopic.php?f=11&t=68

San Disk drives are notorious for problems like this.

Sounds like an incompatible flash drive. Take a look at: http://forum.atvflash.com/viewtopic.php?f=11&t=68

San Disk drives are notorious for problems like this.[/quote]

I know this was in reply to the OP, but I’ve got what very much looks like the same problem. In case it’s not clear from the thread so far, the “IOBase address :0x0000” line is from a block of interface details (like what you’d get from ifconfig). It appears after a screen and a half or so of boot messages, and looks like it immediately follows a failed dhcp attempt (can’t tell for sure with the left of the screen cut off). In any case, the interface appears unconfigured.

It seems very strange that incompatible flash would cause things to start and boot but then fail during the boot. The thread isn’t specific about the symptoms seen with incompatible flash – do these symptoms fit?

Any thoughts re: the earlier suggestion in the thread about wireless connectivity being the cause?

thanks,
Josh

I can’t say for sure, but I think that the AppleTV just needs to have an Ethernet connection on the initial patching. After the ATV is patched, then you can use wireless all you want. I’ll try patching my AppleTV on wireless and see what happens.

On a side note not related: I really need to buy a second AppleTV to do all the testing for this board, I hate having to restore my AppleTV over and over again to hopefully recreate the problems and fixes. :frowning:

Success! I unhooked my AppleTV from my TV set and took it down the basement and hooked it via Ethernet cable to my router. Went through the aTV Flash install and just left it there for 30 minutes or so. Couldn’t see what it was doing because I had no TV to hook it up to, but when I brought it back upstairs and hooked back up to the TV set, lo and behold, there it was, installed just like it was supposed to be. I even did a little net surfing on my HDTV last night.

Thanks to all. The Ethernet solution seems to be the one.

I’ve now go the problem solved, too, but not in the same way mcullison did.

I tried that first, bringing a wired-to-wireless bridge into the room with the TV and connecting the AppleTV to the wired side. It was clear from the boot messages that it did successfully get an IP (i.e. the details of its behavior were not the same as when I was experiencing the problem) but still ended up hanging.

So next I tried a different flash drive (Aptiva 2G, $14 at Office Depot). In order to isolate the two potential issues (wireless vs. USB drive) I put the AppleTV back on the wireless network for this attempt, and it worked on the first try. So I guess it was the USB problem all along, as ‘aTVFlash’ suggested. (Original drive was a 512M Cruzer.)

It was very surprising how much the bad drive appeared to work … it was clearly loading and booting a kernel, and running startup scripts. Huh … anyway, clearly that was the problem.

thanks for the help.

Josh

It is definately not the because it’s a wired connection. I have the same USB drive and I did run it through a hard wire to the router. I’m off to get a different flash drive to fix this problem.

Does anyone actually know what it is about a given USB drive that might make it incompatible? Ignoring the U3 ones for a moment, it is just a formatted memory device, and as long as it allows itself to be formatted as Mac OS extended why should it matter what the brand is? Anyone know the technical reason why some fail?