aTV Flash for 1st Apple TV and Mac OS 10.10

I have my mac running OS 10.10 and trying to use aTV Flash installer for 1st generation Apple TV (Silver) I get the message the installer needs Java SE 6 to run, and the link to apples support page doesn’t work. Can anyone advise how best to do this ?