ATV Flash Finder rebooting on Windows Media stream

… when trying f.e. to open:
http://www.zdf.de/ZDFmediathek/content/859200?inPopup=true
I have browsed through the forum but could not find any hint except that there might be “too much data” involved in that stream.

ATVFlash v. 3.6.4
installed: Flash Player, Flip4Mac, QT plugin, mplayer,

Thanks for any feedback.

EDIT 10/13: I also tried http://mediathek-video.br-online.de/o16/br/b7/player/public/b7mediathek.html?bccode=bfs using aTV Flash Internet app - with the same result: Finder is rebooting. Also the Firefox application cannot display the stream (windows stays empty, Finder reboots after leaving Firefox)

Adobe Flash may not have been properly enabled. There is a guide for doing this here:
http://wiki.atvflash.com/index.php?title=Enable_Flash

Thank you for answering.

  1. I used Pacifists “Open Apple Install Discs” on my old Mac OSX upgrade (Tiger) DVD.
  2. When extracting the file “CoreAudioKit.framework” I end up with a folder rather than a file which contains 1 alias (exec) file “Core Audio Kit”, 1 alias folder “Resources” and one folder “Versions”
  3. I moved the CoreAudioKit.framework folder to the Documents Folder on AppleTV.
  4. Although I had installed Flash priorly I again navigated to Maintenance > Install Extras and selected Adobe Flash
  5. A screen appeared saying something like "Dependencies installed, restart Finder? - Yes.
  6. Still - when navigating with CouchSurfer to the stream URL the Finder reboots (although it seems it takes him a little longer than before)

Is there anything I missed?
Kind regards, Axel

PS: Sorry - I did miss that there is a related thread in the support forum I have copied this post there: http://forum.atvflash.com/viewtopic.php?f=5&t=1857