aTV Flash cannot start the install for AppleTV (1st Gen)


aTV Flash installer has been successfully installed to USB drive (“Installing aTV Flash windows part1 step9”). However my AppleTV cannot start to read the installed program when power on.

  • The software version of AppleTV (1st gen)  is ver.3.0.2
  • aTV Flash is ver.4.3.1. 
  • USB drive is reformatted for this installation by FAT
  • installation work is worked on windows vista home premium edition.

 I tried to install again and again, but result is fail…would someone please give me advice.

It’s most likely related to a flash drive compatibility issue. We’ve found that about 15% of flash drives will not be recognized correctly by the AppleTV.

Do you have an alternate drive you can try?

I have now tried 4 different USB sticks - all different brands and none of them work! I get the aTV Flash logo then it disappears. The aTV light flashes on and off on the front of the box but no other screen prompts. Not a happy customer after the “simple to install” sales pitch when I when purchased. Please help/guide.

Thanks, James.

Have exactly the same problem. Tried 4 different USB sticks. Also removed U3 - but apple TV still starts-up the old way - without reading the USB.

Any suggestions appreciated




The software version of AppleTV (1st gen) is ver.3.0.2

  • SanDisk Cruzer 2GB with U3 : Did Not work (was unable to uninstall the U3 software, website link had issues)
  • Kingston 2GB: Did not work (Both this and the above mentioned Sandisk were attempted from a Windows 7 Starter laptop)
  • Went to Micro Center and got their store brand 4GB ($5.99) decided to install from a PC running Windows XP, first crack at it... IT WORKED!!!

So please use this info to the most of your ability, it might be the flash drive or it could be the OS… Don’t lose faith!!!