ATV Flash 4.1 causing blank screen - HELP !

Hey All,

I’m posting for my next door neighbor who struggles with technology at the best of times.

She has an ATV and I helped her install ATV Flash 4.1. I did a complete factory restore on the ATV, did a software update to get the ATV to the latest firmware. All easy.

I then installed ATV Flash and that went well. Ran the installer update via the Maintenance Menu and all ok so far.

Attached an external hard drive (USB) and enabled via the Maintenance Setting menu. Drive found and enabled. ATV resets itself per normal operation.

ATV starts up, displays the boot screen and animations (no sound) and then nothing. Blank screen. Can hear the menus being selected, but nothing is displayed.

I’ve tried re-installing about 5 times now. Each time I get the same results. As soon as I enabled the external drive, it all stops working.

I’ve reformatted the external drive, tried a different drive, even tried going back to ATV 4.0.6 but nothing works.

It’s very frustrating and to be honest, a real pain.

Anyone got an idea of how to resolve this?

Cheers

Sonski

What type of drive are you using? Is it setup as primary or secondary storage?

It’s a Seagate 500 meg 2.5" drive in an external case. It’s been setup as the primary drive.

Worked in the past as a primary drive on my ATV.

Does that help?

A black screen after startup usually indicates the drive cannot be found. You may want to ensure the cables are securely connected, and the drive is powered on.

You are not the only one. Same results. Now i have a paperweight that clicks when I hit the remote.

The drive is definitely turned on and connected. I’ve checked that a number of times.

Seems a strange problem. There must be a fix as it basically renders the ATV useless at the moment?

Was the AppleTV system software updated recently?

I did a clean factory install of the ATV software and then did an upgrade to the latest ATV software. I then installed ATV Flash and ran the upgrade via the maintenance menu (per ATV instructions).

As soon as I enable the external drive as the primary drive, I get the blank screen problem.

Can you connect the Apple TV via RGB Component cables? If you can “hear” the clicks of the remote but not see the Menu, it could be a resolution issue when connected via HDMI cables. If you reconnect the old RGB cables you might then be able to see the screen in a lower resolution. I had a very similar problem with an error message stating that the current video format could not be displayed. The movie at the time was an HD movie that had previously played b4 without any problems. All I was left with was the “clicking” of the remote. I reconnected the Component RGB cables and my video came back. Did a complete factory reset, reloaded everything and now all works fine. I think that my ATV just needed to be wiped clean for a new start after 18 months of being completely full with video files. Works alot faster and more smoothly now.

Seems my problem has gone away.

I recently upgraded my video card with the Broadcom card for better playback and resolution. At the same time, I did a clean install of ATV and also enabled the external drive for storage. Boom - worked perfectly.

I’m wondering if it’s a video output issue as per the previous post above?

Max moderator, please pay attention:

I cannot “go-through Maintenance Check for updates -> Manage Plugins menu”. that the screen is black and can not even see or read anything.

PLs, I am interested in having a factory restore it again but the screen went black,
for the 10 minutes the screen saver starts, but I can never see the main menu.

Thanks for your time. I wait your answer.

If you want to perform a Factory Restore and start fresh, the restore option can be accessed through the Recovery Menu. More info here: http://support.apple.com/kb/HT1560

Hrudy,

I had the same problem. After updating to the new version trough “maintenance” the “screen” went blank after restart.
I heard my remote was “bip”-ing as its supposed to be, after I observed the welcome video followed by a blank screen.
When I tried the “screen resolution” routine with the remote (menu + “+” for 6 sec) I have got the picture back temporarily for resolution settings.

Beside that, nothing was working normally. Just a huge pile of blank nothing on the screen.

Luckily, I have got SSH access to AppleTV, so I tried my rusty unix skills to bring it alive as I was suspecting, something is holding back “Finder” start normally after the boot sequence. After I logged in thru SSH I made the root partition writeable as it is set to ready only, normally.

sudo mount -uw /
Disabled NitroTV, after gained root access by
sudo su -
and
cd /System/Library/CoreServices/Finder.app/Contents/PlugIns/
mv nitoTV.frappliance …/Plugins\ (Disabled)/
exit
sudo reboot

So, that resolved the problem, I do enjoy AppeTV with ATVFlash.
I hope, it will help you to located and resolve your problem too.

Cheers,

Maxim

ps: you have got quite a handful of plugins in /System/Library/CoreServices/Finder.app/Contents/PlugIns/ so disable the suspicious ones if your root cause of the problem is not NitroTV, but let’s say, Remote HD or anything else you might have a broken update with.

Hi - I got the same problem. However, this was after trying to mount my time capsule through the network settings of nitoTV. I got an error message when pressing “mount drive” after entering all required information, and then it came with the message “press play/pause to restart appletv”. After restarting, going throught the apple logo, apple tv intro, etc. it came to blank screen at the menu options, though I could only hear the clicks from going through the different menu options.

The exact same thing you’re describing happened to me.

And I just purchased aTV Flash a couple hours ago!

Now my AppleTV is a brick :frowning: — all it does is display a black screen and flash the LED orange when I press a button on the remote… I don’t even get a beep any more…

The steps here should resolve your issue.
http://forum.atvflash.com/viewtopic.php?f=6&t=3323&start=30#p13977

Thanks for the link to the info about deleting the “mounts.plist” file. I didn’t see it until this morning… last night, I ended up doing a factory restore and software upgrade. I re-applied aTV Flash, and silly me, I tried adding a network share and it “black screened” AGAIN. I ended up having to do ANOTHER factory restore / software upgrade / aTV Flash.

I’m leaving it in this state (and not trying to use Nito TV) until the aTV Flash devs release a stability fix. Needless to say, as somebody who paid good money for a nice, simple out-of-the-box upgrade for my Apple TV, I’m pretty disappointed so far!

Yes, the upcoming version will have improvements to ensure a corrupted or incomplete mounts.plist file does not cause issues such as this.

I have exactly the same problem… I just spend $50 to break my atv!!! Is there any solution? - seems this thread has been going a long time with no results.

Have you tried the steps here? http://forum.atvflash.com/viewtopic.php?f=6&t=3323&start=30#p13977