ATV Files won't play mp4 files


I have a problem which came up just a couple of weeks ago, maybe because of the update of Perian! But I am not sure. I have some 720p mp4 files on a external harddrive which used to play but then all of a sudden ATV files and nitoTV are not able to play these files anymore. When I click on them either the screen turns black and the finder restarts or the AppleTV freezes with a black screen and I have to restart the AppleTV manually. This is really annoying because the used to play!

Does someone have an idea of how to fix the problem? Can I go back to a previous version of Perian? Is Perian causing the problem?

Thanks a lot for any help…

Your best option would be to remove and re-install Perian. This can be done through the Maintenance → Install Extras menu.


I tried that already. I also toggled the Apple H.264! When I deactivate it, the movies work but they are very choppy! Same is with Boxee! Thats why I played them with ATV Files because there they where shown absolutely fluently and smoothly! Any other ideas?


I am having the same problem Did not see a solution posted for David.

You may also try disabling the ‘Apple H.264’ option located in the Maintenance → Settings menu.

 I am having the same problem..I cant play my mp4 files. Has anybody found a solution for this?

To clarify the file starts with sound and no video but then it freezes.

Here is the info on the file:
Format : MPEG-4 at 916 Kbps
Length : 650 MiB for 1hr 39min 4s

Video : AVC at 785 Kbps
Aspect : 1280 x 544 at 25.000 fps

Audio : AAC at 128 Kbps
Infos : 2 channels, 48.0 KH

Which menu are you using to play the files?  Have you disabled the 'Apple H.264' item as described above?

 Thanks it worked...I deactivated H.264 in Nito and it worked. When should I use this option(Apple H.264? 


In theory you should never need to have it enabled - though some purchased iTunes content may play better with it enabled.

A lot more things are coming out in mp4 rather than avi format. On my Apple TV (silver 1st generation), I find that mp4s play back very jerky. I have turned off H264 in Maintenance and reinstalled Perian, but that does not help.


Any ideas?



I am also curious if anyone has had success with the newer x264 .mp4’s that the scene has begun making standard.  I cannot get them to play in Files, Nito, or anything else.


edit: should have tried the h264 disable in Maintenance first, now they are working fine.

I am also having the problem with MP4 playback on the ATV (silver).  I tried to disable the H264 and am having the same problem with the jerky playback.  Any solutions here?  Please help.

I have that same problem and I’ve followed the steps above.
I’ve got ATV1. ATV Flash is turning out to be a bit of a nightmare.
I wish I stuck with my old patch stick with Boxee as at least it simply worked and played all files!!

According to Apple support website, Apple TV does support MP4 files. However, Apple TV only play MP4 files encoded with H.264 or MPEG-4 video codec as well as AAC audio codec. However, MP4 is a multimedia video container format which may encoded with different video or audio codec.

If the MP4 is encoded with MPEG-4 AAC or H.264 AAC, we can successfully stream MP4 to Apple TV for easy playback MP4 on widescreen TV. If the MP4 file is with the right video codec but wrong audio codec like MPEG-4/H.264 AC3 or other audio codec, we will only play MP4 with no sound on Apple TV. If the MP4 is with the wrong video codec, we cannot even transfer MP4 to Apple TV, let alone to play MP4 on Apple TV.

In order to solve Apple TV won’t play MP4 files issue, a recommended solution is to convert Apple TV unsupported MP4 to Apple TV more compatible MP4 with iDealshare VideoGo

Any new advice for this same issue?

I have ATV1
I have installed Perian
I have disabled Apple H264 Codec

Still black screen with sound but freezes the ATV