ATV crash/reboot when changing to external storage

Hi all, I read tons of forum messages and tweaked a lot but with no prevail.

1.5TB WD drive (yes, I disabled the VCD), formatted to Fat, empty, brand new.

When switching to external as primary my ATV attempts to synch files onto it but crashed after 2 seconds and reboots. I changed from internal to external many times, always the same.

Also: when in external mode, my ATV still finds all music that are on ATV and plays it there too. Just video is not available (but comes back when switched back to internal).

This is weird and time consuming, thanks for any help.

What method was used to format the drive in FAT32? You may try using the tool at the link below.

Downloaded the tool but can’t run it as it asks for admin rights, well: I am logged in as admin, its the only account on my computer!

OK, I ran it AS ADMIN and it startd but now it tells me my HD ist write protected, starts the Windows format facility in between multiple times and throws errors at me. I can format NTFS both on the HP tool and Windows but not Fat32

Apparently it stopped complaining, it shows that it is formatted as Fat32, connected to ATV, set as external, transfer screen on for 1 minutes, ATV reboots, HD remains empty… I am close to give up and ask my money back. I wasted many nights over this now :frowning:

While (after trying several times) the external drive remains empty, why does ATV not recognize 90% of the movies in MyMovies but does play 10%, obviously still from the internal drive while the external is on…? This is all very strange.

After more trying: ATV attempts to transfer onto the new external but reboots after a minute, it is fat32 formatted with the recommended tool but it does not work

You may try reformatting and leave the ‘Quick Format’ option unchecked. This will ensure a complete format.

Did this yesterday already, again today - same result: ATV attempts to transfer and reboots after 1 minute. External HD remains empty :frowning:

Could this be a AppleTV problem? Would factory restore help?

It’s more likely to be an external drive issue. What name did you give the drive? Were you prompted to select the drive from a list when switching to external iTunes storage?

no, i gave it no name and no list to pick from was offered, should i give it a name? which one?

there is one more issue (an apple one) which might be related or not: some movies do ot sync back to itunes, apple was unable to help me

Formatted again, i get an error message that the drive can not be made dos bootable, important?

Are you formatting the drive using the tool referenced here:

yes, that’s what I wrote above… the drive’s name shows in nito’s files option but i don’t et any selection for any drive when switching the usb drive to external

at this rate (1 message back and forth every 24 hours) we’ll never get anywhere :frowning:

i bought the drive ONLY to use it with atv, now the 7 days have passed when i could have brought it back to the store, including atvflash thats a 200 bucks investment that does not work at all, really frustrating

trying again and again… every time i select external, atv crashes and reboots, same old story…

Now, which allocation unit size??? The tool only formats with 32768 and not as shown in th screen shot with 4096. I get an error message "This drive has more than 2^28 clusters, try to specify a larger cluster size or use the default "

will this ever end??? I have spent 7 evenings now