ATV Bufferring - I know it's been asked before....

I have searched through some previous post and tried several things suggested. Hoping that I am missing something.

All my files are stored on a WD MyCloud ULTRA dual drive. Only one drive is used for the movie files. I run those files (most files are mkv) hardwired networked to a router. Router is hardwired to the Apple TV 4K. Some Remux 4K files 50-70GB will buffer at random times during the movie. Large 1080p files 20GB+ will buffer more often on the 1080P ATV (wireless connection). I believe it has to do with the file size because I didn’t ever have this issue with files on either one that were much smaller. After a TV upgrade to 4K I decided to start downloading some better quality movies. I replaced all the ethernet cables with Cat6 10Gbps cables today and I get the same issues. I tried to switch from Auto to Legacy with the same results. I also did a speed test through inFuse on the movies I have tested. ATV4K is averaging 71Mbps and ATV1080 is 22Mbps. Not sure if that means much.

Today I paused a movie as soon as it started and move the cursor to the 7 min mark to see how long it would take for the movie to load that far. 7 mins of waiting and it is at the 6 min mark. Im guessing I would wait 5 mins each time I start a movie and I could get through it ok. I am trying to avoid that though.


Linksys AC5400 Router
ATV4K (Hard Wired to Router)
WD MyCloud Ultra (Hardwired to Router)
Cat6 10GBps Cables
Internet Speed (250 Down 50 Up) - I know shouldn’t make a difference but in case someone is curious.
Also use a ATV Gen 4 1080p on another TV.

If someone needs more info please let me know.

What setting did you change from Auto to Legacy? SMB or Cache?

Have you done a speed test for that share and one of the files that buffers on you from within Infuse? If so, what speeds did you get?

I did the speed test within Infuse on the individual files. ATV4K(hardwired) is averaging 71Mbps and ATV1080 (wireless) is 22Mbps

After reading your response I went back and didn’t see a way to Speed Test the share itself or folder. I only see an individual file. I pretty much get the same speed on all the files I test within the share.


First and easiest is to try setting your Streaming Cache to “Legacy” in the Infuse settings. This may or may not help but worth a shot.

I was referring to how you have to navigate to the share in the settings to do the speed test.

SETTINGS > SHARES > SAVED SHARES > SPEED TEST > Select share that holds file to be tested and navigate to that file > Select file > START TEST

That tests the speed to the specific video on that particular share.

Does Your device support FTP? If so you could try enabling that on your mycloud and then try connecting to it with FTP on your AppleTV. Other users have shown massive speed increases doing this.

I tired the Steaming Cache to Legacy and didn’t see a difference. Yes that is how I was doing the Speed Test.

I finally got the FTP set up. I did a speed test and it went from 70 to 90 on the ATV4K and the ATV4 1080 went from 20 to around 50. A quick check of the 1080 seemed to be improved because it wasn’t buffering. I will have to find time this week to watch a large file 4K movie this week to check that. Those files were harder to check because the buffering was less frequent. Thanks for the help so far.

I am still open to ideas if anyone else has anything. I will update the post once I watch the movie. On a side note does anything think the speed of the drives has anything to do with it?

Probably not. I have 5400rpm drives in my synology however processor will have an impact. An arm processor will push out files a lot slower than an intel one.

Additionally if you have a ton of stuff connected to your router or are running any over the top services on your router (website filtering, parental controls, intrusion detection, antivirus or QoS) that will also impact network performance.