aTV (black) dead

I bought aTV Flash today for my new Apple TV (black). I connected the Apple TV unit to my iMac (Snow Leopard) with a micro-USB cable and ran PwnageTool. I followed the directions from the FireCore Support page. I successfully entered DFU mode. I then went to iTunes (latest version) to restore using the PwnageTool generated file (AppleTV2,1_4.1_8M89_Custom_Restore.ipsw). After attempting it, iTunes tells me "The Apple TV could not be restored. This device isn't eligible for the requested build." There's other threads regarding this issue, so I won't touch on it here.

My problem is that I can't get iTunes to restore my Apple TV (black) using ANY file. I have tried using  the Apple TV 2G (4.1/8M89) file (AppleTV2,1_4.1_8M89_Restore.ipsw) that I got from and I have also tried letting iTunes download the newest softward itself and installing that. It can't restore. I tried to connect my Apple TV (black) to my LCD TV, as it's been for the past 3 weeks (and working fine). The unit is just dead. The white light blinks, but it's no longer functional.

How can I recover my Apple TV (black)? Thank you.


ya i had that unplug the HDMI and re plug seems to be a video bug.

Wow. After hours trying to rehack that thing while USB-connected to the Mac, I couldn't get it to work. Gave up and went to sleep. This morning, re-plugged it in again, like you said, and it's working. I'm REALLY grateful, but I hate that I don't know what as wrong.

I'm not installing ANYTHING from FireCore until it's out of Beta mode.

Thanks for the help.


No prob dude!and the newer version of aTV is fine.


look the worst that can happen is you have to restore


but really it installed really fast and all good,

This error often happens ether when you are selecting the wrong firmware file for your device or if you do not have the shsh files saved for the firmware version you are trying to downgrade to.


Read more about it here: