aTV Basic Installation

Being new to mac, I am having basic issues, which hopefully someone can resolve .

I’ve tried two different USB stick, one being the 1Gb Usb2 DataTraveler which is recommended as being recognised by the Apple TV. Installed Atv with the OsBoot monted.

Got the right install message remove stick at the end of the installation.

Restart the Apple TV with USB plug in , but nothing happen. I’;ve clearly missed something there, and it getting frustating 1!!!

Can anyone help please ?


aTV Flash does have issues with some USB drives, especially ones bigger than 2GB. Do you happen to have an older one that is 512MB - 2GB? You can see compatible flash drives here: If that doesn’t seem to be the problem then let me know and I can try and help further.

Thank you for your answer, I’ve actually specially bought the 1Gb Usb traveller from Kingston on the recommendation of this web site! I’ve tried a dozen times but without success ! Sorry to be a pain,

Don’t worry about it, I’m here to help as best I can. Try this and let me know if it works, I posted this in another post a while back:

Apple TV Installation & Setup
I have 2gb Kingston data traveler usb and the flash drive installation was done with no problems using vista.

Put in apple tv blinked hesitated, brief green screen, then booted up with no atvflash just regular apple

what next

tap tap…this thing on, oh, it is, Helloooooooooooooo

Kingston drives have been known to have compatibility issues on the Apple TV. The install will complete just fine, but it will not be recognized by the Apple TV.

Do you have a different drive you can use?

I HATE saying the same things over BUT it looks like MANY of us are having the same problems. Where is ANY SUPPORT? I am a Mac user for over 6 years and had NO trouble created the boot stick… I made one using a 4gb DaneElec AND a 1gb Kingston Data Traveler . Both sticks had NO trouble during the stick setup procedure. They BOTH completed successfully.


BOTH sticks… I placed in the USB port of the ATV while the power plug was OUT. I then reinserted the power plug. The Dane stick reboot did totally NOTHING, the ATV started as usual as if that stick was not present. The Kingston stick, The ATV started then hesitated foe a split second on a green scree blip, then resumed again as if no stick was present. So here are 2 different BRAND sticks, HOW PICKY can this be?

So what is the solution? Now I have 2 USB Flash Drive sticks PROPERLY LOADED with the atv software and it simply will NOT work. I have looked at the boards and even tried the disk Utility as suggested partitioning each stick TWICE. Again… I am left here with a $49 bill and NO product to speak of… Is THIS MY FAULT? I have entered this agreement in good faith, I read the contract, I PAID the fee (Legal consideration), so now what is atv’s end of the agreement? I am SURE they would much rather HELP and make everybody happy. So please, if you are reading this… H E L P !

Try this out and let me know if it helps you.