ATV 4K not releasing disk space as expected

ATV 4K recently keep cleaning all my cached metadata autocaially from infuse and showing warnings like too much space from infuse. Actually, it only 200-300Mb metadata in infuse and I can’t stop it to clean my data it frequently happened

2 Likes

i would suggest submitting diagnostics in the app and posting the code displayed so the devs can get some info.

After that, Can you try changing you Streaming Cache setting to Legacy or memory only?
I have noticed that the new streaming cache system is using up all available system storage, causing lag and very slow seeking, also system reports of low disk space, triggering the metadata clear as well. Doing this has stopped this issue for me.

You can use the free app “Top” to view realtime storage and memory use on the ATV, switching back and forth between it and Infuse during playback is where you can see how much resources it is really using.

thx for your kind advice.I realized it only happened after I switched cache setting from legacy to auto 3 days ago. atv keep cleaning my cache after I switched to auto cache mode. I’m going to switch to legacy now and see what’s going to happen , I will update the result here again

1 Like

The same thing is happening to me and I didn’t switch the cache setting, I use an embry server. It’s the second time in 3 days this happens and I have 20GB of free space on my Apple TV.

“Auto” is the default setting since the update it seems.
Have your tried changing it to Legacy or Memory only to see if that resolves your issues?

I didn’t try that. I’ll try it to see if it resolves the issue.

I’m having the same issue since 2 days ago as well. Was there a recent update that changed anything?

The 7.3.8 update (submitted to Apple today) has a few changes which should help with a few cases of this we’ve seen.

7.3.8 will most likely be available on the App Store early next week.

Same problem here James. Reinstalled meta data 4 times in last week.

Hi, how do I change this setting? Thanks

Infuse settings under playback, look for Streaming Cache settings.

Great. Thanks NC

I’m not sure that Infuse is doing something “wrong”, but here is what started to happen with Infuse 7.3.7. Something hinky is going on with available storage on my Apple TV. Installing a new app in the App Store suddenly failed, with the error message that there was not enough free storage space.

So I ran som tests:

  1. According to the app “SpaceLeft TV” there was only 100MB of free storage space.

  2. Restarted my Apple TV 4K. There was now 11GB available storage.

  3. Ran Infuse 7.3.7, and no other app, for a few of hours and available storage was down to ~100mb again.

  4. Device reboot frees up space every time, and allows me to install new apps.

Either tvOS itself or Infuse fills up all my storage, but the “Ultra-optimized streaming cache” mentioned in the Infuse release notes, sure makes me suspicious.

1 Like

Yes infuse will use disk space for cache in addition to memory as of the new release. You can change the behavior in playback settings to memory only or legacy.

1 Like

Think the default setting should now be legacy setting IMO.

1 Like

Totally agree! It’s not OK that a default setting makes problems for other apps and the App Store.

2 Likes

Hello, same problem here, when I start a movie , it will load the data into disk space and stay there, I loaded three times the same movie ( a 3.3 GB movie) and ended with 9GB in the disk space,. The only way to flush the disk space is doing a restart of the. Apple TV. The new super buffer does not reset the downloaded data when finished.
Is there a way to return back to the 7.3.6 release of infuse ?

Today’s 7.3.8 update has a few improvements and fixes for issues we have seen reported since the release of 7.3.7.

Please give this update a try and let us know if you run into any further issues.

Thanks for your patience.

Hello James, I tried the 7.3.8 release and the streaming cache bug is still there. I loaded a 3 GB movie and it remainded stuck in the Apple TV 4K disc space memory. I also tried to reload a second time the same movie and now there is a 6GB data stuck in memory disc space memory. Eventually all the disc space will be full. The only way I found to flush the disk space is by rebooting the Apple TV.
Thanks for your help

Envoyé de mon iPad

Can you send in a report (and post the code here) if this appears again after a restart?