ATV 4k BDMV inside AVCHD

Hi guys,

long time reader, and patron. Infuse has been one of the best blessings for Apple TV and you guys have done a great job updating the interface. This is my goto app for streaming content from my server.

I have been backing up my triple layer discs as they seem prone to playback issues with almost any minor scratches/dust on the disc. Infuse is able to recognize the AVCHD folder format, and play the 4k content over ethernet pretty well (wifi stutters).

I have an oppo uhd player as well, and I name my folders with the movie name say Gladiator/AVCHD/ under which will be BDMV folder, oppo can do Dolby Vision playback with this method, and I can understand ATV doesn’t do dual track DV playback at this time. However Infuse is not able to pull any metadata for folders like this. Is there anyway to fix this, or can infuse add this to the features to be able to recognize movies in this folder structure?

Thank You!

Edit: I did have another question, on tvOS 11.4 is the audio pass through available, I tried turning it on today, with reduced loud sounds disabled, but there was only some hissing and white noise sounds. So is the feature not working right now?

1 Like

So I did find a rather simple work around, just creating a shortcut of the underlying BDMV folder next to the AVCHD, works for both infuse and the Oppo. Infuse is able to pull metadata for the content and play the file clicking the thumbnail. This will work out for me.

I did want to find the answer for the audio question if someone looks at this.


At the moment Audio passthru is not working due to changes that Apple made at the TVOS Level. There is some speculation that the ATMOS support announced for TVOS 12 might make this possible again but at the moment nobody really knows.

I tried this but infuse does not recognize the folder. Do you rename the shortcut to BDMV? I did that but it does not seem to work.

Anyone got this working?

Yes the folder has to be renamed to BDMV. So it looks like
“Movie Name Folder”> “AVCHD” & “BDMV” folders
that should show the art and play the movie from it.

EDIT: I also believe this works only on NFS, SAMBA doesn’t seem to work with this work around.

I have this same setup, well a Cambridge CXUHD to be exact, and I can’t seem to get this work around to work. I have a Synology NAS with UHD backup folders with AVCHD folders inside containing the BDMV folder. Infuse is connected via NFS.

I can play the folders on the CXUHD and Infuse, but I can’t get Infuse to pick up the metadata. I have a created an alias (shortcut) using OSX and tried Movie Name-BDMV-alias and Movie Name-alias, but it doesn’t work.

Do I need to create the shortcut in Windows? Will it work with the files stored on a Synology NAS?

It would be great if Infuse recognized the AVCHD folder structure without having to implement a work around.

Make sure it’s a NFS share, anything else like SMB and infuse can’t pickup the AVCHD folder.

Thanks. I do have Infuse connected to the NFS share. Infuses sees and plays the AVCHD folder but it’s not picking up the metadata. It’s just a folder that I can navigate in Infuse. I tried creating the shortcut from a windows machine and it’s the same result.

Do you have your files on a Synology NAS or somewhere else? I wonder if the NAS is the issue.

Okay. 2 different things. your Cambridge player needs the AVCHD folder, not Infuse. Infuse needs the BDMV folder or shortcut inside the movie name folder for it to get metadata and stream the movie.

So it should look like this:

Movie name folder say: The fast and the furious
Under this should be BDMV folder or shortcut for infuse to work. And also AVCHD folder so you know in your cambridge which movie you’re trying to watch by name.

I have my old Comp working as a Linux server, with NFS and SMB shares. It should work just fine either way.

Thanks. This is how I have it setup. I’m not sure why it’s not working. What did you use to create the shortcut?

In linux: ln -s AVCHD/BDMV BDMV

I suspect this might be the issue. The Synology OS doesn’t allow for shortcuts, and it doesn’t recognize shortcuts created in windows or OS X. Might have to see if a symbolic link or something else works.

Alright I figured this out. For anyone using a Synology NAS, you need to create a BDMV folder in the root folder of the movie and mount the contents of the BDMV folder in the AVCHD folder in the root folder BDMV folder.

Unfortunately, you can’t do this with the Synology GUI. You need so ssh into the NAS and add a mount command to /etc/rc.local file.

So it would look like this:

sudo vi /etc/rc.local
sudo mount --bind /path to BDMV folder inside AVCHD folder /path to BDMV folder inside movie folder

You can also enter the mount command in terminal, and it will mount the folder and work, but the mount will disappear when you reboot the NAS. Editing /etc/rc.local will mount the folder on reboot.

Hope this helps anyone with the same problem and setup.

Glad you worked it out! I don’t think the audio pass through works, as it seems it got bugged at some point in 11.xx , Firecore did report this to apple, but I don’t think its been fixed yet.

Thanks. Your posts certainly helped along the way.

BTW do you notice any difference in video quality between the oppo and Infuse playing UHD Blu Rays in HDR10? I’m wondering if I can move the Apple TV into the home theater or if I should stick with the Cambridge for all movie watching. Infuse certainly has a much better user interface.

The oppo started doing DV conversion of HDR10 discs on the fly a little while ago, the 10 to 12bit conversion helps some with the banding on my LG Oled. So I tend to keep a full backup of my discs, and use oppo for that. I use infuse when there is Cinevia added to an UHD, only a few of them, but they are there. And of course where my 2nd tv, is Infuse works just fine. I don’t think I have seen a particular difference in the video quality. But the oppo definitely is faster to playback stuff. I do love the Infuse interface as well, wish Oppo supported something like that, but that won’t happen.

I’m running into the same issue with no metadata showing up for my UHD Blu-ray rips into AVCHD folder structures which contain BDMV and the associated CERTIFICATE folder. All these movies show up in the other category with no metadata and all are named AVCHD. I’ve ripped all of my Blu-ray and UHD Blu-ray discs in this format so they’ll work over SMB shares with both my Oppo UDP-203 player and also with JRiver Media Center on my HTPC. They play fine in the Infuse app (I went with the annual Pro subscription for now), but just have no metadata. I tried the trick of creating a shortcut (in Windows 10) to the BDMV folder described above and then removed and re-added the shared folders to force Infuse to do the metadata lookups again, but it didn’t seem to work.

It would be really nice if support could be added to take care of loading metadata for the …\MovieName\AVCHD\BDMV folder format. With support for this, the app would be really useful to me, but without it it really won’t be as it’s far too much work to redo all my movie rips and I’d end up with them no longer working on the Oppo and/or JRiver Media Center in the process.

Overall, this is a pretty slick app.

Has anyone ever figured out how to do this under windows (smb)? I have my UHD discs on a 10Tb usb drive shared and I can’t figure out how to get the metadata and full menus to work with Infuse Pro 6.0.x

Any ideas?


Support for this type of organization is something we’re currently working to add, and plan to have available soon. :slight_smile:

… |___ AVCHD
… |___ BDMV