ATV 4K 2022 DV playback with only audio but no video, just black screen

Hi guys!

I bought my new Apple TV 4K today, and I have exactly the same issue with it.
The video file is the same I think, Andor S01E09 and S01E10, and there is a problem with Blade Runner 2049 as well.
There wasn’t any issue with my old Apple TV 4K 2017.
Plex played the Blade Runner without any problem on the new Apple TV 4K 2022.

Got the sample. Thanks!

Looking into this…

1 Like

I’ve tried again.
Match Dynamic Range and Match Frame Rate turned on
Passed HDMI test.
Same issue. Only audio, black screen.
The video file “loading” time is 1 minute :grimacing: :thinking:

I bought a new HMDI 2.1 cable yesterday. Sandstrom Gold series HDMI 2.1 up to 48 Gbps.
No luck.

I’ve tried today :

Andor—H265, HEVC, Dolby Vision, Version 1.0, dvhe.08.06, BL+RPU SMPTE ST 2086, HDR10 compatible Single track single layer mp4
Apple TV 4K(2017) picture : yes, sound:yes, subtitle:yes
Apple TV 4K(2022) picture: no(black screen) sound: yes, subtitle:yes, DV logo pop up top right corner

Blade runner 2049—H265,HEVC ,dvhe.08.06, BL+RPU, HDR10 compatible single track, single layer mp4
Apple TV 4K(2017) picture : yes, sound:yes, subtitle:yes
Apple TV 4K(2022) picture: no(black screen) sound: yes, subtitle:yes, DV logo pop up top right corner

Both Apple TV 4K settings are same.

This should be resolved in today’s 7.4.9 update. :slight_smile:

Thanks for your patience.

Not sure where it’s fixed because most Dolby Vision is still HDR10 on tvOS 16.1.1. As I can see it’s an OS problem, Apple TV 4K 2022 doesn’t use HDMI extended mode, Apple TV 4K 2021 is fine, same cables, same TV. I hope it will be fixed in tvOS 16.2.

Thank you James, I can confirm it is working now.

1 Like

I would like to clarify, Infuse 7.4.9 switches to Dolby Vision on ATV 4K 2022. The main problem is the new device’s lack of extended HDMI mode. So it’s not an Infuse problem.

Same here. It’s working now properly. Thank you!

Still doesn’t work for me with some files on 7.4.10 (ATV 4K 2022) DV logo pops up in the corner and subs play, but no video. Only happens on some files, not all.

Here’s some mediainfo with two examples:



Where can I get these files for tests ?

I tried uploading them to Onedrive. Unsure if there is a better solution, the files are pretty big.

Downloading. They will be downloaded in 3 hours :slight_smile:

I will test later today.

Tried one of the 2 files.
Does NOT play (black screen) on my Apple TV (2022).
Does NOT play on 2 Macs (M1 Pro and M1 Max)
Does play OK on iPad Pro 12.9 2020, iPad mini 5 and iPhone XS Max.

All with the latest non beta Apple OS.

My test results:
Chernobyl and GoT
iMac (macOS Ventura 13.1)- black screen
iPhone (iOS 16.2) - playback is okay
Apple TV 4K 2021 (tvOS 16.2) - playback is okay, Dolby Vision

Please do not post links to copyrighted materials.

Okay, sorry about that. I was thinking of just posting a 30 second clip or something but didn’t want to modify the file in any way.

Seems like people are confirming the issue though. Weird that they work on some hardware and not all. They work on my old ATV 4K 2017 but not the new 2022 one.

“Funny” thing: on the Mac, where there is a black screen for playback, the thumbnails when scrubbing are working (they are not just black).

I have an odd discrepancy with two devices when I try playing a movie.

Room 2 plays the movie fine.

Room 1 plays audio fine but doesn’t have video. However, when I fast forward the thumbnail in the bottom does show the video preview.

Room 1 Setup

TV: Sony A90J
Apple 4K: 3rd generation
Apple TV OS: Latest (non-beta)

Room 2 Setup

Apple 4K: 2nd generation
Apple TV OS: Latest (non-beta)

Both Apple TV’s are 1:1 with how their video settings are configured.

HDMI directly connecting both TV’s and Apple TV - no receivers, etc. in between.

I’ve tried a different HDMI cable to eliminate that.

All devices are on the same network and have similar speed test results.

Media is in a Synology.

File size: 72GB

File type: MKV

Note, I’ve tested larger files (>80GB) and they’ve played fine.

I can’t move Apple TV’s between rooms due to where they’re located.

Thanks for any thoughts or suggestions!

1 Like