ATV 4K 2022 DV playback with only audio but no video, just black screen

I’ve replaced my ATV 4K 2017 and ATV 4K 2021 with 2x ATV 4K 2022 models, and DV files play audio only with black screen. Same files used to work with the 2 previous models. Also, I’m using the most recent Infuse on them with tvOS 16.2 Beta 2 installed, just like with the previous models.

Anyone having the same issue?

Thank you

Did you go through the HDMI tests and DV tests on the new ATVs?

No, not yet, but I’ll do that now.

Tests have passed. Also, when DV is playing, even though it only plays audio, if I pause it and do the seek to either left or right, the little thumbnail shows the actual content that should play? I’m not sure if this helps?

I’ve had HDMI cables cause similar results. I’d try one of the old units again and see if it still plays the same files.

Also make sure the new ATVs have Match Dynamic Range and Match Frame Rate turned on just to cover all the bases.

Tried it with another HDMI cable as well, no luck. Both match options are on. Forgot to mention that ATV+ DV content plays fine, but not these files that worked on previous units.

Do they give you the DV badge on your TV when you start them?

I’d still give one of the older units a try just to eliminate a connection issue.

Yes, all DV content shows the badge. Okay, I’ll try one of the old units.

So, I’ve connected and set up the 2017 ATV 4K, and it works like a charm, it is the 2022 ATV 4K and Infuse combined causing the issue.

Just tested a DV video in Infuse with an Apple TV 4K 2022 and it played nicely and in Dolby Vision on an LG OLED.

Interesting. Here’s my setup, and also what has changed (in brackets) from the working setup:

Living Room:
ATV 4K 2022 (changed from ATV 4K 2021 which is working with DV) with tvOS 16.2 Beta 2
Belkin UltraHD High Speed 4K HDMI Cable

ATV 4K 2022 (changed from ATV 4K 2017 which is working with DV) with tvOS 16.2 Beta 2
Belkin UltraHD High Speed 4K HDMI Cable

Nothing else changed in terms of setup, apart from switching the old units to the 2 newer ATVs, and it is the same 2 DV files I’m testing with, so I don’t really understand what’s going on? :frowning:

The 2 DV files are:

Dolby Vision, Version 1.0, dvhe.08.06, BL+RPU / SMPTE ST 2086, HDR10 compatible

Dolby Vision, Version 1.0, dvhe.08.06, BL+RPU / SMPTE ST 2086, HDR10 compatible

So again, I’ve reconnected the 2 older units parallel, and they are still working fine, it’s just the 2 new ATVs that don’t play/show video, but audio. (But when seeking backwards or forwards it displays the thumbnail properly.)

If I understand well, dvhe.08.06 means Dolby Vison profile 8, which is not supported on Apple TV (only profile 5 is), so the videos should play in HDR10, not DV.
Streaming services such as Disney+ usually use profile 5, so it is strange to have profile 8 here.

Is Infuse playing the files directly, or is there a middleman such as Plex or Jellyfin?

1 Like

Infuse playing directly from QNAP NAS via FTP connection. Library is synced via iCloud.
All dvhe.08.06 videos are working/playing as DV content on both the ATV2017 and ATV2021 units.
Attached 2 videos as demo of what’s happening:

ATV 2017


As you can see the DV badge comes up on both units.

PS: And this is the LG C1 OLED TV they are played on.

Just played a dvhe.08.06,BL+RPU video with my Apple TV 2022 and Infuse on my LG B8S OLED, with “Match Dynamic Range” and “Match Frame Rate” enabled.
MediaInfo tells of the video stream: “Dolby Vision, Version 1.0, dvhe.08.06, BL+RPU, HDR10 compatible / SMPTE ST 2086, HDR10 compatible”

It plays correctly, but in HDR10, not Dolby Vision.
That is expected -only DV profile 5 is supported by Apple TVs.

It looks like you have a Hue Sync box (I also have one and love it). Is it between the Apple TV and the TV?
If I were you I would try:

  • reset video settings on the Apple TV(s),
  • plug the Apple TV direclty to the TV (if that is not already the case),
  • turn match dynamic range off to force HDR10, DV, or SDR playback.

Otherwise the only difference I can see with my setup is that I have tvOS 16.1 release, and Infuse’s latest beta.

First of all thanks for all the effort you’ve put in.

Yes, I do have Hue Sync box, but all the recent tests I’ve done, was done connecting the ATVs direct to the TV. I’ve tried all the below:

  • Reset video settings
  • Via Hue Sync and directly connected
  • all the variations of MDR and MFR on/off
  • Tried with both tvOS 16.1 and 16.2 Beta 2
  • 2 Belkin UltraHD High Speed 4K HDMI Cables and 1 Non-branded UH speed HDMI cable
  • After resetting video settings the issue is the same for both HDR and DV playback (just black screen with subtitles displayed and audio, but thumbnail displayed when seeking, other HDR content plays fine)

I gave up. I’ve signed up for Testflight now, so I’ll wait and if I get access, I’ll try it for one last time.

Thanks again!

Weird -and unexpected- things happening with Infuse on the new Apple TVs. Like this Movies appear in Other when setting up new device

If the issue is on Infuse’s side, it will very probably be solved in a beta first - so good for you to have signed up for Infuse betas.

Installed the 7.4.8 beta, issue persist with all variations, so I guess I’ll just wait to see if a tvOS or an Infuse update will resolve it.

Thanks again!

Are you able to upload a video sample you are seeing this with so we can try and test here?

Hi James, thanks for coming back on this.
I’ve just uploaded the sample file, and also the 2 videos I’ve posted here about the issue.
( and
Do I still have to send an email, or would you/they know that there’s this post about the issue I’m experiencing?

Thank you!

1 Like