ATV 2 says jailbroke but its not!!

Hi everyone

 

Desperately need some help / advice. I have been using my jailbroken ATV2 for several months with no problems whatsoever, however stupidly I clicked the ‘Update all’ in Nito last night, which effectively broke my ATV2, as it would no longer boot up. Just kept trying to boot up, got to the apple logo screen and rebooted itself alot. Searched online and discovered it was as a result of pressing the ‘Update all’ button, and found advice to Restore the ATV2 in iTunes, then rejailbreak.

I did this, and ATV2 was running on 5.1, but when I used Seasonpass to rejailbreak again, it ran through the jailbreak and the completed screen came up to say it had worked, but when i plugged it back into the TV it had not been jailbroke. I tried this process several times, before returning to the forums for help again, and read that it would be easier to jailbreak if the ATV2 was running on 5.0.1, so restored it back to that and tried again. But still the same thing is now happening. I have tried several attempts to jailbreak, both tethered and untethered, but keep getting the same result. Seasonpass runs through the whole process, and tells me it is complete and been jailbroke, but when I plug it into my TV it hasn’t worked, and I get the generic apple screen with no red firecore logo. I have tried to reset all settings, and used the down + menu for 7 seconds reboot, as some people have advised and that hasnt changed anything either.

Please help me as I loved my jailbroke device, and was about to get rid of Sky as a result!! My ATV2 is currently running on 5.0.1 and I use a macbook pro running on mountain lion.