ATV 2 iTunes Restore "Not Eligible for Requested Build" error.

I've tried various methods of jailbreaking my device and I am always stopped by iTunes and receiving the error mentioned in my subject.

I first attempted to downgrade from ios 4.3 to 4.2 however was not successful due to this error.

I was willing to settle and tried using Seas0npass 7.5 to jailbreak iOS 4.3 and was not successful due to same iTunes error.

 

What is strange is that even if i try a regular restore in iTunes and try to restore to iOS 4.3 using iTunes itself it tells me I'm not eligible for the requested build, which happens to be the version that came with my ATV2, and the most up-to-date iOS...

 

Can anyone help me with this ?

If you're getting the 3194 error when running the latest version of Sesas0nPass you may try adjusting your hosts file as described here:

http://forum.firecore.com/topic/4328

To james, or whomever reads this…

I experienced the same problem as the previous user… Here’s exactly what I did… I got error 1601, then realized that its was most likely my hosts files since I use TinyUmbrella and modified them to downgrade and save shsh blobs. So I removed Saurik’s server and did the restore again. However this time I got a generic iTunes error, with no number…simply saying Not Eligble for requested build."

It’s almost as if iTunes thought I was trying to downgrade, any idea as to what may fix this.

Which version of Seas0nPass are you using?

There are two possible scenarios where this issue can occur.

  1. Your hosts file is set to Cydia's and you are trying to restore the CURRENT firmware. (revert to normal hosts file)
  2. Your hosts file is set to Apple's and you are trying to restore an OLD firmware. (ensure you're running the latest version of Seas0nPass)

How do you revert to normal hosts file?

i had same problem and tiny umbrella helped.

More info on adjusting the hosts file can be found here.

http://forum.firecore.com/topic/4328