ATV 2 iOS 5.0.2 "First Time Jailbreak"

I have been trying to jailbreak an Apple TV 2 for a few days now and cant see whats going wrong!! This unit is loaded with a “never been jailbroken” copy of iOS 5.0.2 (4250). I have tried using Seas0npass 0.9.2b and 0.9.3 to save iFaith SHSH signatures AND i have also tried dumping SHSH using iFaith 1.5.9.

The closest i have got so far is with iFaith which gets to the “validating stuff with Apple” part and then wont go any further. Seas0npass (both versions) just seems to give me an SHSH Extraction failure every single time!

Am I missing something?! Is this iOS version no longer jailbreakable?! Please help. Thanks

From my extensive experience I rather suspect that Seas0npass is failing to extract blobs because they are malformed on this device.  It would also explain why iFaith falters at validating stuff etc…

Terminal, I’m afraid.


Terminal?! Do you mean DEAD, as in not retrievable? OR do you mean i need to use Mac OSX “Terminal”?

I mean that if it is as I have postulated you won’t be able to jailbreak it no way, no place, no how.

You have to understand that I can’t tell for certain that this is your situation but in my experience what you describe fits with this diagnosis. In maybe 400 version 5s I have jailbroken this has happened to me about five times, so you are unlucky.  You could shift it on the 'Bay… :wink:


Huh… Ya i have done a TON of jailbreaks on ATV2’s and never come across this before either. Can I not still upgrade it to 5.3 and do a tethered jailbreak on it though? I would assume that’s still an option because i wont require any SHSH to complete that process. However, I will wait to hear back from you before deciding to go to 5.3 (obviously I would rather not do this)

The OTHER thing i forgot to mention after re-attempting things on this box last night is that i have another Apple TV 2 at iOS 4.2.2 that was doing the same thing identically as the iOS 5.0.2 one. If you are right (and you very well could be), I would find it odd that i would come up against two boxes at the same time that give the same error messages on both computers/programs/methods…

Have you not heard of Murphy’s Law?

Sure you can upgrade to 5.3 bt you’ll lose the ability to dump the older blobs from the device, not that you’re having any luck doing that.  I don’t know how to advise you on that.  I tend to leave all my old bricks on their original firmwares but then I trade them and you possibly don’t have 50 ATV2s adorning your office…


Ya I hear you… I’m not 100% convinced yet on these two devices having this issue but i appreciate your discussion on the matter. I think what i am going to do is try to take them to a friends house and try to jailbreak on yet again another computer. If that doesnt work I may see about selling/trading them. 

With that said, you aren’t interested in two Apple TV 2’s are you?! One on 4.2.2 and one on 5.0.2 :slight_smile: Thanks