Atv 1G + Mac - Lock Settings popup

Hi!

I’ve owned my aTV 1G since last september. I jailbreaked it with Firecores aTVflash on the first day. Since then I’ve done one total reboot and once again jailbroken it.

I also own a Macbook Pro late 2010 which I’ve streamed of since september last year. I have the basic knowlege, so I’ve used SMB share from my computer to my aTV. It has worked flawless, never had any problems with finding and streaming from my computer.

But then last week, suddenly I have no access to my computer. When i click on my shared folders in XBMC i get a popup that says “Lock Settings” and promts me for a username and a password.

I’ve tried using all my usernames and their passwords from my computer, it doesn’t work.
I’ve tried to change the settings for my smb folders so that all the users can modfy the content, no result.
I’ve tried to ssh my way into the aTV to uninstall and then re-install xbmc and all the settings, but the problem still exists.

Does anyone know what my problem might be? And how to fix it?