Attached Supplemental Fonts in MKVs cause INFUSE PRO to crash on AppleTV

I am posting this here in Apple TV as I do not know if this behavior occurs in other platforms

Various MKV files would crash frustratingly on Infuse. I realized that typically they were usually foreign movies with subtitles. I started experimenting and discovered that it was the supplemental font file attachments in the mkv’s that would cause the crash. Removing the font attachments solved the issue. I hope this helps others out, and lets Firecore’s support team to figure out what the problem actually is.

Cheers!

Would you be able to send in one of the files that is causing this issue so we can review it here?

Files of any size can be submitted here.

Thank You

I have deleted the versions of the problem files as they were large and unneeded. . The next time I run into this situation I will send a copy.

1 Like

Thanks for sending in the sample!

In a few brief tests your sample seems to be playing well here, and subtitles (with embedded fonts) are working.

Are you using an older version of Infuse? Can you try installing Infuse 7.2.1 to see if this resolves what’s going on?

I am using Infuse Pro 6