Atmos Core Universe Issue

I have a couple “Dolby Core Universe” demos that I downloaded. One was a m2ts and another was an mkv from https://thedigitaltheater.com/dolby-trailers/. I cannot seem to get atmos playback through Infuse. Can others try it out? And yes I did select the DD+ audio stream once I started playback.

Audio #2
ID                                       : 4353 (0x1101)
Menu ID                                  : 1 (0x1)
Format                                   : E-AC-3 JOC
Format/Info                              : Enhanced AC-3 with Joint Object Coding
Commercial name                          : Dolby Digital Plus with Dolby Atmos
Format profile                           : Blu-ray Disc
Muxing mode                              : Stream extension
Codec ID                                 : 132
Duration                                 : 3 min 7 s
Bit rate mode                            : Constant
Bit rate                                 : 1 664 kb/s
Channel(s)                               : 8 channels
Channel layout                           : L R C LFE Ls Rs Lb Rb
Sampling rate                            : 48.0 kHz
Frame rate                               : 31.250 FPS (1536 SPF)
Compression mode                         : Lossy
Stream size                              : 37.3 MiB (4%)
Service kind                             : Complete Main
Complexity index                         : 16
Number of dynamic objects                : 15
Bed channel count                        : 1 channel
Bed channel configuration                : LFE

Or if someone has a link to one that does work that would be great. Thanks

Someone had a similar problem a few months ago and it was determined that the files just don’t work. Are these the ones that also have a Dolby vision track? I couldn’t get them to play back atmos on my nvidia shield either.