Aspect Ratio Option Broken?

On 5.9.1 is the option to change the aspect ratio broken? I’ve never had a issue until now using this feature. No matter what I select the screen stays the same. Thanks.

Hi guys, I too am having this problem.

Yeah, it seems to be busted on all iOS devices. Hope it’s fixed soon.

Welcome to the forum!

The Aspect Ratio setting is a new option added in 5.9.

Previously, these settings (along with other zoom options) were available under the Zoom Mode setting. 5.9 separates these out into 2 difference settings which allows for more control over how things work.

For example, if you have a 2.40:1 video, and want zoom the video so all the black bars are hidden you have a few options.

  1. Select 2.40:1 under Aspect Ratio and Crop under Zoom Mode. This will remove the black bars, and crop the sides of the video the entire screen is filled.
  2. Select 2.40:1 under Aspect Ratio and Stretch under Zoom Mode. This will remove the black bars, and stretch the video height to fill the entire screen.

In many cases, you may want to crop out some of the black bars, but not all. To do this, simply select a different aspect ratio option (like 1.85:1 or 2.00:1) and your desired zoom mode (crop or stretch).

Thanks for the reply James. That would explain it. I will give it a try when I get home from work today. Appreciate it!

Actually it’s still broken. The way James describes is how it is supposed to work but it doesn’t. As soon you enable crop in zoom, it automatically fills the entire screen. Changing most aspect ratios doesn’t do anything. I sometimes like to use 2.00:1 as it’s a nice balance between black bars and full zoom. Leaving zoom in normal doesn’t any changes to the aspect ratio. Am I missing something? I am at work now but the only thing I didn’t try is selecting the aspect ratio first and then selecting crop. It doesn’t work the other way around.

Is this happening with all files, or just a few?

Do your videos have the black bars cropped out already by chance?

If you are able to send in a sample we can review it here to see if we can replicate the same issue.

HI James, thanks for the very quick response. I added to my comment just before you responded. Is it also possible to default to an aspect ratio (2.00:1 in my case) for all 2.35:1 or 2.40:1 files? Thanks.

I just tested it here, and it doesn’t seem to matter which setting is adjusted first (as you’d expect).

The only thing I can think of is your videos may already have the black bars cropped out, which could be affect how Infuse handles the zoom. If you get a chance to send in a sample it could be helpful.

With regard to default settings, the zoom mode will be retained (Normal, Crop, Stretch) but the aspect ratio is unique to each video. However, if you are using Pro, a video’s aspect ratio setting is synced to iCloud and will be available on other devices if you resume the video, or rewatch it in the future.

I’ll send you a sample video. Thanks.

The 5.9.4 update, which was released today, includes a few extra changes which should allow the Aspect Ratio option to work correctly with videos which do not contain embedded black bars.

Thanks James!

I have a (tangentially) related issue – I have made full SBS encodes of my 3D movies with the black bars removed, so the aspect ratio ends up as 3840 x 800 or similar. I need to be able to stretch these out to 3840 x 1600 plus black bars so that they’ll play in the correct aspect ratio when I tell the TV it’s looking at an SBS video. I don’t seem to be able to manage that with any of the aspect ratio / crop / zoom settings in Infuse 6. Is there something I should be doing, or an easy option to stretch the video but not so that it fills the whole screen?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.