Artwork shown in iOS but not on Apple TV

Hi all, can anyone help with this problem, its driving me crazy.

Some of my 4K movies are not shown with artwork on the Apple TV but the artwork is showing just fine on the iPhone/iPad app.

Welcome to the forum!

Have you tried the “Refresh Metadata” option under Settings > Library?

Also, do they show up on the ATV when you view the “Recently Added” like your showing on the iPad?

Thanks :slight_smile:

I have tried but of the suggestions and the artwork is still not showing

And what about under recently added on the ATV?

Also, do you have both 4K and non-4K versions of the ones not showing posters?

Could you provide an example of how you have the the files named on the 4K version of a couple of videos that are not showing posters?

Same problem, missing artwork

How do you have the files named?

I have both 1080 and 4K of each movie, both formats are located in separate folders on the NAS

| HD

Infuse is setup to look at the stop level Movies folder.

Each movie file is named in the following format, MOVIENAME (YEAR).mkv

So are you seeing the posters on the ios device for 4k and not on the ATV? That’s what the original issue is.

That’s correct

Are you looking at the movies in the library or on the share? What do you see when you click on the black poster for one of the 4 k movies?

Do you see the poster for the 1080p version on the ATV?

When I view the movie details I see the the same artwork as shown previously, missing artwork

So you have 2 movies, 1 4K and 1 1080p both with the exact same name but in different folders?

Do you see any textual metadata?

Correct, same movie same naming structure in different folders

Text metadata is shown and it’s correct

So there’s no difference in the names denoting resolution, compression etc. between the 4K and the 1080p?

What happens when you do an Edit Metadata and reselect the correct choice for the ones with the black poster?

The files are named exactly the same but as mentioned they’re in different folders.

When I edit the meta Infuse finds the correct meta for the movie but the artwork fails to change.

Do you by any chance have " Embedded Metadata" turned on in the ATV settings?