APTV4K(1st Gen) FileShare MacMini

I have a 2018 Mac Mini (OS 11.5) that currently works well with the Infuse 7 app on my APTV4K (1st Gen) and the Infuse app on my IPad Pro (2018). However, I also have a Mac Mini M1 (OS 11.5.1) and until today, that too worked well with the Infuse 7 app on both the IPad and APTV4K. Sadly, I can no longer get it to work with the APTV4K, but sharing still works with the iPad.
I think I have tried just about everything to make it work with the APTV4K but to no avail. In my numerous attempts to get it to work, I did discover one strange thing; and that was that if went through the “forget this share” process on the APTV, the M1 Mac Mini would magically reappear as being shared with Infuse7 even though it had been deleted. However, the indexing failed message would appear when during the update process.

Any ideas how to fix this please?

I have just reinstalled the app and it still only works with the OS 11.5 Mac Mini. I can only assume that Firecore is not compatible with the latest Mac software.

There are a few things to check.

  1. SMB is enabled on your Mac (more info here Set up file sharing on Mac - Apple Support)
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above)
  3. The folders/drives you wish to share are added to the list of Shared Folders
  4. Selected username and password are being entered in Infuse

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: Set up users, guests, and groups on Mac - Apple Support

Also, if you’ve recently installed an update for macOS, you may need to disable and then re-enable File Sharing to get it working again.

Thanks for the prompt reply, but I have done all of the above. It was working fine up until a few days ago, and 5ge file sharing with my iPad works fine too.

Can you send in a quick report from the non-working device (and post the code here)?

QS5YJ. Not sure if that relates specifically to the non working device.

After disabling the working device, the code is CGA7Q

I believe that James was asking for a diagnostic code from the ATV4K that can not connect to the Mac Mini that it had been connecting to in the past.

I did the “forget this share” thing on the working device. The second code is after the working device had been forgotten.

Which ever ATV no longer connects is the one that a diagnostic is needed from.

If it’s working now and there’s not a problem then maybe the share just got corrupted and needed to be added again.

It’s still not working. I have changed the password on the non-working share, as it was previously the same as the one for the working share and I thought that might have something to do with it. The relevant code is now 5JB4G

Code after reinstalling the app: SZYEP

Update: it no longer works with the iPad. But the sharing function still works between each MacMini.

Update 2

I have tried sharing from a MacBook Air (10.14.6), and that encountered the same problem as the MacMini (11.5.1) i.e. they are shown as available shares but the APTV4 app repeatedly fails to connect. But if the app is closed and then re-opened, both computers will be shown as saved shares, although the Infuse 7 is incapable of display files connected to those computers.

In the meantime, the Infuse app works fine on the iPad for all three computers.

Update 3 a miracle has occurred and everything is working fine again. I shall keep my fing

*fingers crossed!

Update 4: indexing failed for the Mac Mini that was previously functioning.

Your logs indicate Infuse is unable to locate the Mac mini on your network, at times.

This has a few potential causes.

  1. Are you using Wi-Fi or Ethernet for Mac and Apple TV?
  2. If using Wi-Fi, are you using a single network for both 2.4GHz and 5Ghz, or separate networks?
  3. When Infuse is unable to connect, can you ensure the correct device name is still listed on your Mac in System Preferences > Sharing > File Sharing?

There are some situations where a Mac may disconnect and then reconnect, but the name it previously used is still assigned by the router. In this case, macOS will add a number to the device name. EG My-Mac.local may change to My-Mac-2.local

I have never encountered an issue of not being able to locate any of the sharing Macs. It was simply a question of being unable to connect. However, behind the scenes, the problem seems to have corrected itself without any conscious intervention from me. So, thank you. All seems to be working perfectly now, at least for the time being. However, I do have two remaining issues, which relate to family share, which I have set up for my wife so that she can use Infuse 7 on her iPad.

Firstly, it wasn’t clear from the download in the App Store, whether she has had to pay for the privilege, as I think no additional payment should be involved. Is that correct? Secondly, we are unable to connect to any of the Mac shares,

PS wife’s access now working