AppleTv won't connect to wifi

Hi everyone!

 

I new here and trying to fix my apple tv 2.

Whats wrong: my apple tv 2 is running 4.4.4 for years now, pretty much since apple pulled the 2nd gen was taken of the market.

 

The appletv basically wont connect to my wifi... I get the connection error..

 

But i know my wifi works because all my laptops and other apple tv 2 works perfectly fine..

 

Would anyone know why this is happening also how i can fix this? 

Also what should i do about updating? I don't mind leaving it at 4.4.4. But cant do anything till i get wifi to work on the appletv. 

 

Message i get after putting in my wifi password

"There was a problem connecting to the network. Check your settings and try again. (0)

you have to rejail break it, but before doing it wait a while to see if ios 7 is released if not it’s likely you have all the signitures saved all the way up to 5.2(only if you have the flash installed or you clicked on nito tv)

I ended up working around this error by making a second SSID through my router. my router has the option to make a second wifi network. i made it unsecured and the apple tv was able to connect to it fine. in order to “secure” my onenetwork i use mac address filtering. put in the mac addresses for my iphone and apple tv in order to just allow it to those devices. i still have my old network that i was getting the error with and it works just fine with all other devices except the apple tv.

guys had the same error.
turns out that the atv had no space left in it.
I deleted a lot of garbage in local and rental with ssh.
and deleted some stuff in xbmc .
then i tried to connect to my wifi network. it worked like a charm

Could you elaborate on how to clean out the junk so I can try to see if that will solve my connection issue?

I used cyberduck on my MacBook , nut You can use putty for Windows to.
Google is youre friend.
I found the necessary information on the web

Thanks. I know how to connect but how I do know which files I can delete without causing trouble?

First places to check are: /private/var/mobile/Library/Preferences/XBMC/addons/packages,

/private/var/mobile/Library/Caches/AppleTV/Video/LocalAndRental

/private/var/mobile/Library/Caches/AppleTV/Video/Other

Be careful !
Somewhere in which path i can not remember is a map called partial .
Do not delete the partial map.
If You do that . then You can create the map partial back.

Thanks. I’ll give it a go :slight_smile:

Thanks so much. Got in through Cyberduck and cleaned out in the XBMC folder and them I was able to reconnect to my wifi. Will safe this guide for later should it happen again.

you can also clean out unused space by sshing in through terminal and typing the following commands:

apt-get clean
apt-get autoclean
apt-get autoremove

Thumbnails can also be a problem in xbmc and take up serious amounts of space, the simplest way to clear that is to navigate to the xbmc folder then user data then delete the thumbnails folder, then navigate to database and delete textures16.db