AppleTV Won't Connect to NAS

Hi All,

I’ve just jailbroken my AppleTV 2 and all was well but I’m now experiencing a problem with accessing media on my NAS drive.  The ATV is connected wirelessly to my home network and is accessing the internet fine.  However it will not access my NAS drive and reports an AFP error.  I’ve tried to ping the ATV from my MAC and that is also timing out.  How can the ATV be connected successfully to the internet but I’m not able to access it over the internal LAN?  Anyone experienced this problem?  The odd thing was that it suddenly connected to the NAS and I was able to browse my media without issue.  However on startup today the problem is back.  I’m at a loss to explain this behaviour.  

I’ve set the ATV with a static IP but this does not seem to have helped.

 

UPDATE:

After leaving the ATV connected for about 5-10mins it has reconnected to the NAS and am able to ping the ATV.  Is this normal?  Why does it take so long for the ATV to connect to my local LAN?

 

A few things I’d try;

  1. Set your aTV to auto-assign an IP. Unless you’re forwarding ports there’s no real reason to use static IPs.

  2. Being on the internet is not the same thing as being connected to your NAS. If you have a router and you can connect to the internet from your aTV you are on your network. That doesn’t necessarily mean you can access your NAS.

  • Turn on your aTV, wait for it to get an IP, ping it from your computer or use the web browser to hit a site.
  • Access your NAS from your computer.
  • Attempt to access your NAS from your aTV. If you can’t, it’s a configuration problem on the aTV.
  1. What type of NAS do you have? If it’s not an Apple product, try using SMB instead of AFP.
  • Create a share on the aTV using the IP address of your NAS in the Network Address box
  • Try to browse to your files

I use an external HD connected to my PC, and it will go to sleep after so many minutes of inactivity. If my aTV is also sleeping and I turn it on everything works first try. If I pause a show, then let my aTV go to sleep when I try to resume it will kick me back to main menu. In case your NAS is going to sleep (just a guess since I don’t have one) try browsing it on your computer first then try on your TV.

[edit]

Does your NAS have a name on the network? If none of that works try IP/name, or just name in the Network Address box where name is what it’s called on your network.

You can also try the steps from fireCore’s guide here: http://support.firecore.com/entries/20322512-streaming-from-a-mac-pc-or-nas

[/edit]

I had it on auto IP and changed it to static as this always seems to help with these things! I’ll change it back.
When it was on auto IP I was getting an IP address from the router but I still couldn’t ping the Atv. I never have problems accessing the NAS from my MAC or PC.
I’m using a Synology DS207+ which is supposed to be compatible with AFP protocol and works fine on a MAC. It even has Time Machine support which works fine. I’ve already setup a share on the Atv and as I said it works fine. However after a shutdown and restart it seems to take an age to connect back to the NAS.

I’ve tried using both the IP address and the name but this doesn’t change the problem. I’ll investigate the sleeping issue on the NAS which might be causing the problem. However the Atv should wake the NAS up like the MAC does. I’ll check and see what I can find.

Same problem here after instelling THE new unthethered version and ATV flash 1.5. Notering works afp/nfssmb, but THE rest om my computers and tv (Philips) van acces the shares drive.

Is there à fix?