AppleTV will not turn on

Hi,

I have a problem that my ATV2 will not turn on (no lights).

Here is what I did.

 

Jailbreak the ATV2 using the latest version of SeasonPass.

All went fine. I was able to SSH in and install xbmc and such.  Keep in mind I did all of this not attached to a TV.

Next day. Noticed the light was off. Pressed menu on the remote and the white light apperead again.

I was also able to log in via SSH.

 

Next day, same thing… But it did not want to turn on with the remote.

Thought maybe because this time it was not plugged to the TV.  Plugged in via HDMI… No Go

Unplugged the power, Ethernet, replugged… No go

Waited till after work, still the same issue.

 

I went into Itunes and did a AppleTV restore and Update. Process went OK, no errors.

 

Plugged again the power and HDMI… Still does not want to go!

 

I tried again to plug the USB cable only and the white light opens.  The remote also works because when I press the Menu and Play buttons for a while, it enters DFU mode.

 

Can anyone help me ?  Or did it brick itself ??

 

Thanks!

Try unplugging it then open iTunes then plug the USB and then the power. Leave it for a few seconds then switch the USB with the HDMI.
It’s a tethered boot.

Edit:

Sorry just noticed you restored it in iTunes. I would exchange it then.

Hi,

I tried it and still no go.  I will be contacting Apple Care to get a new one!

 

Thanks!

Hi,

I got a replacement from apple. I did the jailbreak following instructions and all is working as advertised !

 

Thanks!