AppleTV + network drive attached to Time Capsule

Hello, this is one again post about attached/network drives and NitoTV… apologies, but such a sore subject seems to concern a lot of us.

My set-up : AppleTV (brand new) with latest AppleTV 3.0.1 software / ATVFlash 4.0.3 + Time Capsule with attached WD MyBook (FAT32). AppleTV and Time Capsule are connected with ethernet cable.

The error message I get from nitoTV :

Network Mount Failed! usage: mount_smbfs [-Nh] [-l host] [-M cmode[/smode]] [-O cuid [:cgid]/suid[:sgid]] [-R retrycount] [-T timeout] [-U user] [-W workgroup] [-d mode] [-f mode] [-g gid] [-n long] [-u uid] //workgroup;][user[:password]@]server[/share] path

My Share point settings are :

Mount name : VIDEOS
Mount type : smb
Mount adress : Time-Capsule.local (I have also tried with the Time Capsule IP address -
Requires Authentification : yes (I have also tried with No)
User login : ATV
Password : xxxxx
Volume path : VIDEOS
Auto mount : on
Use custom path : off

On Time Capsule, File Sharing is activated and protected with user passwords. I have also tried with Time Capsule password.
I can mount the hard drive both from my Macbook and a PC.

Can somebody give me some pointers ?

One suggestion for the ATVFlash support team : you guys should rewrite/update your wiki page about NAS streaming ! It’s very light, doesn’t cover a lot of issues, and too many people are having problems with this…


Has the Smart Installer been ran and AppleTV restarted?

Yes to both.
Does the error message tell you anything as to where the problem lies ?

Here’s an update – weird :
my set up works with Boxee but not with nitoTV !

On Time Capsule I have changed File Sharing protection to disk password. Boxee sees Time Capsule and the attached drive. I can navigate thru my movie files. It’s a breeze.
But with nitoTV, I still get that annoying message error when I try to mount the share…


I've the same issue, does anyone has an answer?