AppleTV Install Issue - Flashing "?"

Hi All,

Hoping someone may be able to assist. I installed the ATV Flash all ok via flash card, as per instructions and received confirmation at end of install to remove flash card and restart Apple TV.

I did this by powering off unit (unplugging) removing flash card, then powering back up.

Got Black screen (no apple logo) for some time, then ended up with a small APPLE TV logo (vs the normal silver APPLE logo) with a flashing question mark ‘?’ above it. This has stayed on screen for 10-15 minutes.

I am tempted to force a restart (MENU + ‘-’) but up till this point all has been done (and worked) as per PDF instructions.

Any assistance would be appreciated!

P.S. Now I am a little concerned…after half an hour of the ‘apple tv logo’ I went for a restart MENU + ‘-’ via the remote.

Basically a repeat behavior has occurred - black screen for 2-3 minutes then the apple tv logo and flashing question mark.

NO option for a factory reset, which at this stage is my preferred option - to at least have my ATV working even without the hack extras. :? :cry:

A little more info that may help.

I went back and created a 2nd flash stick. I only included the ‘default’ options - non of the advanced options.

Went and installed on APPLE TV - the ATV Flash logo came up, then install text flowed through, with the final response ‘OK to remove flash card and restart Apple TV’

In reviewing some of the code however (which I’m a complete novice with Unix - hence why I paid for the GUI option ATV Flash provides) it does reflect a few ‘errors’ :

Mostly this appears in the final install section ‘aTV Flash Apple TV U/G’ - just before you are told all is good and can restart the machine.

Of mounting OSBOOT partition
a3: No such file or directory


Installing aTV Flash
not create directory ‘/mnt/OS Boot/seedscratch/users/frontrow’
no such file or directory

cannot mount /mnt/osboot - invalid argument

It seems to refer alot to OSBoot - which am aware is the disk image we had to have to create flash file in first instance…I had this and downloaded it as per instructions from the following URL: http://www.atvflash.com/downloadme

Please can you advise if there is an issue with this file else what the below errors allude to.

Suffice to say, upon powering up ATV after removing the flash card, I am again back at the small Apple TV logo with the flashing question mark - no option to apply factory reset or return to a working machine.
:? :? :? :expressionless: :expressionless: :expressionless:

Do you have access to ssh in from Terminal? If you can SSH in then you might be able to do something to stop the rebooting. Remember that you have to use this:

ssh -1 frontrow@AppleTV

or

ssh -1 frontrow@192.168.1.x

I tried to do this wirelessly but get response:

mattys-macbook-air:~ Matty$ ssh -1 frontrow@AppleTV
ssh: Could not resolve hostname AppleTV: nodename nor servname provided, or not known

Also tried AppleTV.local

mattys-macbook-air:~ Matty$ ssh -1 frontrow@AppleTV.local
ssh: Could not resolve hostname AppleTV.local: nodename nor servname provided, or not known.

cld not try I.P. as not sure what it is.

Shld this work wirelessly or will i need to hook up macbook to ATV with ethernet cable?

Thanks
Mathew

You can use a program like BonjourBrowser to search your network for Bonjour devices and you should see your AppleTV somewhere in there. If you drop down the arrows, you will see an IP address. Give that a shot and let me know.

Hi, Ok installed Bonjour Browser (thanks for the tip!) but on Macbook Air nothing re ATV shows up.

On my IMAC I do get something but think its more related to the synching to ITUNES than the actual machine itself…please see attachment…tried to connect with IP’s that show but as per screen dump of terminal I am getting PROTOCOL errors.

MattyM-IMac:~ Matty$ ssh -1 frontrow@AppleTV
ssh: Could not resolve hostname AppleTV: nodename nor servname provided, or not known
MattyM-IMac:~ Matty$ ssh -1 frontrow@AppleTV.local
ssh: Could not resolve hostname AppleTV.local: nodename nor servname provided, or not known
MattyM-IMac:~ Matty$ ssh -1 frontrow@10.0.1.197
Protocol major versions differ: 1 vs. 2
MattyM-IMac:~ Matty$ ssh -1 frontrow@10.0.1.197
Protocol major versions differ: 1 vs. 2
MattyM-IMac:~ Matty$ ssh -1 frontrow@192.168.181.1
Protocol major versions differ: 1 vs. 2
MattyM-IMac:~ Matty$ ssh -1 frontrow@192.168.32.1
Protocol major versions differ: 1 vs. 2

Thoughts???
Thanks again, Mathew

Hmm, it seems your AppleTV is not even getting an IP address since it is not showing up on your network. Do you have a hub or switch that has the green/orange lights when you plug in an Ethernet cable? When you plug in the AppleTV does the light come on and blink?

hmmm…not sure what you mean…ATV was getting an IP previously as has been working fine until attempt to install the aTV flash. I have an Apple Time Capsule/Base Station and it is showing steady green light. Is this what you mean?

Also, I tried to re-install in hope it may show IP address in install routine…no such luck, however I did note that once i re-inserted my flash card, the flashing question mark ‘?’ disappeared, leaving just the apple TV logo…after a few minutes the system auto ‘rebooted’ and started the install routine again (aTV logo appears, then install text etc).

Upon subsequent reboot (power off/on, remove flash card) I’m back to my ‘unique’ ATV logo and flashing ‘?’.

Seems that the install is still ‘wanting’ for something further, even though it says it was successful each time?

Also, not that I’m worried of not having it, but my flash install pkg did not give me options to include ATV or Sapphire etc…I am a bit confused as there is reference in the forums to NOT select these due the recent APPLE TV upgrade, however I dont even have them to select/deselect (which for the moment I suppose is a good thing…I was thinking of removing the ATV which is apparently causing many users the looping reboots).

Appreciate your ongoing assistance…sure the solution is out there not too far away :slight_smile:

Howdy

i also found this from the APPLE Support Site - seems the flashing “?” is due to system unable to find startup files on HDD…why has my flash install changed this?

The below suggests to take the unit into APPLE to be fixed - sure they’ll be happy with me … NOT ;-(

If we cannot resolve the ATV flash procedure can we at least get ATV to read its own startup files please?

Apple TV starts up to a flashing question mark
Last Modified: March 28, 2007
Article: TA24604
Old Article: 305164
Products Affected
AppleTV
A question mark that flashes on and off on your television may indicate that Apple TV cannot find the startup information on the hard drive. This generally indicates there may be an issue with the Apple TV hardware. In the United States, bring the Apple TV into the nearest Apple Store. In other regions, bring the Apple TV into the nearest Apple Store or Apple Authorized Service Provider (AASP) for evaluation.

Hi,

Any further thoughts? As per my original post, there seems to be an issue with reading/mounting OSBOOT - would this then prevent the ATV from even reading its own files from the HDD?

I’m really concerned now as only had the ATV for just over a week and it’s currently a complete BRICK with a flashing ‘?’ !!

Please help! Appreciate all assistance thus far.

P.S. I have tried again numerous times to access via SSH, just no go. If you can give some detail/options if feasible to access via hooking up macbook via eithernet cable or whatever, I’ll give it a shot…just need some clear instructions to follow :slight_smile:

Cheers

From your issue - the only good thing I can see is that you have only had the Apple TV a week. Meaning, you can exchange it for a new one with no problem - no matter which store you bought it from. (pain in the ass to return it though i know)

One good thing is that the issue is an issue people get - even without patching their machines - so taking it in for exchange will not raise any eyebrows.

Sorry - I don’t have anything good to offer - other than you should be able to easily get a new unit. The issue you are having is the first time I have ever seen it reported on this forum…

Just wondering : You didn’t use a Apple TV patchstick from another site in the past did you? Some other people here will know more but there were some bad patchstick images going around on the net a while ago from a similar product that would brick peoples units.

Thanks, yes I heard of those ‘other’ sites and stayed clear. I was looking, but in the end it was the referral from SCREENCASTSONLINE that sent me this way. Also it was GUI based which suited me not being fully proficient in Linux/command line work.

Yes I will consider taking back and pleading ignorance re ‘hacking’…but if they were to diagnose the unit could they not tell this. As it only happened since first trying to install with the flash process, I was really hopeing for a way to ‘rollback’.

Seems I may need to bite the bullet though… thanks for your feedback.

This may not work, but what if you say something to the effect of, “My power went out at my house and when everything came back up, I received this flashing question mark.” I don’t know if they will believe that, but it might be worth a shot. This way it gives them a “reason” to explain the problem, not just a blank stare from you when they ask “Why?”

yep I suppose I could do that…funny the power did go out suddenly today, so I wont be telling a full firfie :slight_smile:
I have booked in for a session tomorrow so will see how we go.

They wont be able to detect though that its tried to be ‘hacked’ - spose not if it cant even read its own HDD?

I dont think I’m keen to reattempt to hack this (hoping they give me a new unit or fix), so could i please request a refund for the patch? Shld I email support to arrange this?

Thanks for your persistence however, appreciated.
:cry: :expressionless: