appletv black jailbreak does not work

hi,

the jailbreak - as described on your website - does not work. itunes does not let me upload the AppleTV2,1_4.1_8M89_Custom_Restore file. therefore i cannot proceed to the installation of the fire core software. i am talking about the new apple tv 2nd generation (black). Any proposals? if not - how do i get my money back?

Thanks

M

I to am having the same problem... Is this company a scam?

Unfortunately if your AppleTV is not yet jailbroken you will need to wait for the upcoming 4.1 jailbreak. Please see the sticky announcement here: http://forum.firecore.com/topic/3418

Hi it seems like it doesn’t. I was misled too. No where did it say you need a jb Atv 2g. On top of that no jb for 4.1.1 for windows users.

This company is not a scam! It’s in “Beta” version which means not all the bugs are worked out. Read before you buy something and don’t assume it’s gonna work right away! And if you don’t know about “jailbreaking” don’t try until a 1 click jailbreak comes out.

If you google Jailbreak apple tv 4.2.1 there are ways to jailbreak it with tether it was a pain for me but I got it.  It takes time and retries if you dont really know your way around using terminal.  All I can say is trial and error and read alot.  I have now done my apple tv 1g and 2g.  This is a legit company I know have nitotv, couch surfer pro installed.  I opened my 2g apple tv around 9 am today.  Very happy thank you firecore

[quote="clarks.4162"]

If you google Jailbreak apple tv 4.2.1 there are ways to jailbreak it with tether it was a pain for me but I got it.  It takes time and retries if you dont really know your way around using terminal.  All I can say is trial and error and read alot.  I have now done my apple tv 1g and 2g.  This is a legit company I know have nitotv, couch surfer pro installed.  I opened my 2g apple tv around 9 am today.  Very happy thank you firecore

[/quote]

 

But you are able the jailbreak-teather mode only.  As soon as you remove power, the apple tv 2g is locked up and you are stuck.  Am confused because to jailbreak means to connect a cable to the USB port, with NO POWER.  Cable between APPLE TV 2G and a computer (MAC or PC).  But as soon as you jailbreak-teathered, you are stuck, because you can not now turn off power.  Since you are powered only via the USB port, that can be called "un-powered".  Then connect the Apple TV 2G to your television and powerup the first time.   From then on, you must nver turn off the apple tv 2g. 

Do I have this correct?  

 

I'm having the same problem. I've looked everywhere. There should be a new jail break out soon. I just bought my ATV2 today.

Follow this and you wont have problem make sure that you follow Steps 7 thru 10.  Connect power cord then set to DFU mode with Power Cord Connected.  I just had to do it today

 

Before you proceed with the jailbreak, you will need the following:

  • A MicroUSB cable
  • iOS 4.2.1 for Apple TV
  • PwnageTool 4.1.2 ( 4.1.3 is untested but could potentially work as well)

All download links are posted at the end of this article.

Step 1. Download PwnageTool, PwnageTool bundle for Apple TV iOS 4.2.1 firmware and Tetheredboot utility for Mac. Move PwnageTool to OS X’s Applications folder, and everything else into a new folder named “tethered” on the desktop.

Step 2. Open the Terminal app on Mac OS X

Step 3. Run the following commands (this will fail if you didn’t move files to the required folders as mentioned in Step 1)

 

cp -r ~/Desktop/tethered/AppleTV2,1_4.2.1_8C154.bundle/Applications/PwnageTool.app/Contents/Resources/FirmwareBundles/


Step 4. Start PwnageTool and select iOS 4.2.1 for Apple TV to create a custom firmware for your device. Save this custom .ipsw file in the same “tethered” folder on the desktop.

NOTE: Do not install any packages through Cydia in Expert mode, this produced very unpredictable results.

Step 5. Back in the Terminal, run the following commands:

unzip -j ~/Desktop/tethered/AppleTV2,1_4.2.1_8C154_Custom_Restore.ipsw 

 Firmware/dfu/iBSS.k66ap.RELEASE.dfu kernelcache.release.k66 -d ~/Desktop/tethered/

Step 6. Restore the Apple TV to the ~/Desktop/tethered/AppleTV2,1_4.2.1_8C154_Custom_Restore.ipsw firmware using iTunes. Note: Your Apple TV SHOULD be in DFU mode after finishing up with PwnageTool.

Step 7. Unplug and then replug the USB, after the Apple TV has finished starting up (will be blinking steadily), plug in the power cable.

Step 8. Run the following commands in Terminal:

cd ~/desktop/tethered

 ./tetheredboot -i iBSS.k66ap.RELEASE.dfu -k kernelcache.release.k66

NOTE:  It will loop a complaint re: DFU mode, just ignore this, once you are finished getting in DFU mode tethered boot will take over.

Step 9. Now manually put the Apple TV in DFU mode. (*DO NOT USE PWNAGETOOL*)

To enter DFU mode manually:

  • Connect your Apple TV with your Computer via microUSB.
  • Now reboot your Apple TV by holding down Menu + Down buttons together for around 6 seconds.
  • After reboot, immediately hold Menu + Play until you see the message in iTunes saying that Apple TV in recovery mode is detected.

Successful output from tethered boot will look something similar to this:

Initializing libpois0n 
No matching processes belonging to you were found 
Waiting for device to enter DFU mode 
Device must be in DFU mode to continue 
opening device 05ac:1227… 
Found device in DFU mode 
Checking if device is compatible with this jailbreak 
Checking the device type 
Identified device as AppleTV2,1 
Preparing to upload limera1n exploit 
Resetting device counters 
Sending chunk headers 
Sending exploit payload 
Sending fake data 
libusb:error [darwin_transfer_status] transfer error: timed out 
Exploit sent 
Reconnecting to device 
Waiting 2 seconds for the device to pop up… 
opening device 05ac:1227… 
Uploading iBSS.k66ap.RELEASE.dfu to device 
[==================================================] 100.0% 
libusb:error [darwin_reset_device] ResetDevice: device not responding 
libusb:error [darwin_close] USBDeviceClose: no connection to an IOService 
Waiting 10 seconds for the device to pop up… 
opening device 05ac:1281… 
Setting to configuration 1 
Setting to interface 0:0 
Uploading kernelcache.release.k66 to device 
[==================================================] 100.0% 
libusb:error [darwin_transfer_status] transfer error: device not responding (value = 0xe00002ed)

Step 10. If all went well, unplug USB and plug in HDMI and your Apple TV should be ready to go. You will need to repeat Steps 7-9 every time you restart your Apple TV, this isn’t a convenient process by any stretch!

Once you are done with the jailbreak, you can install the following apps on your jailbroken 2nd-gen Apple TV:

 

can someone post the steps to jailbreak this device using windows applications

thanks

 

Hey,

I've managed a tethered JB for aTV2g on 4.2.1, yes it was a a bit painful...but got there in the end. I installed aTV Flash(black) but now can't get it to reboot correctly via tether after the install. How did you do it?! :/

 

Scratch the above..., I've worked it out. 


Once you've installed the aTV Flash(black) software, you must reboot via tether, rather than let the installer control the reboot. Same for installing last.fm and nito etc...click no to reboot and do a tethered reboot once all are installed.

Working beautifully now!

Cheers FireCore team, nice piece of software.

This is so frustrating. I use the isntructions above and I keep getting a "Wrong Firmware Bundle Selected Error" in Pwnage Tool 4.1.2 & 4.1.3.

If I try another site I and I get the Apple TV could not be restored. An unknown error occured (1601)

Arrrgghh!  :(

I probably should wait for the proper Jailbreak to be released, but I'm busting to do it now!

I've tried to search for a video of this process but couldn't locate anything. That's even frustrating as people put "Apple TV 2G" in their title when it's clearly for other devices.

Anyways if anyone has any other info that'd be great and I'll continue to keep on trying. :)

hi ryanm.105362

was there anything in addition to the tutorial above that you did? Did you manually type commands in or copy and paste? did you unzip all files?, etc, etc?

 

I've downloaded all the files, unzipped them and put them all in the appropriate places as outlined in step 1.
I copy and paste the code into Terminal and it returns:

-bash: PwnageTool.app/Contents/Resources/FirmwareBundles/: No such file or directory

I manually type it in and it returns:

cp: illegal option -- /Any 
usage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file target_file
cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file ... target_director
I'm not sure if this is what is supposed to be returned in terminal?

@all

Follow this instruction.....and everything works perfect including Network and WiFi ( still tethered) with the current iOS (shown as 4.1.1 in the apple TV)

 http://www.youtube.com/watch?v=4EWKr7Ww_c0

It looks like its all down to fooling iTunes from accessing:

gs.apple.com.akadns.net on Port 80 TCP.

Anyone have any ideas of accessing and finding how iTunes accesses this port o what access list it is looking at has the key to make this work.

 

Cheers

J

Cheers bodoe.6280 it finally worked! :)

It's similar to the previous post here, and still a mission but it was great to have some visual instructions for the layman out there! I recommend peoples go over to http://www.youtube.com/watch?v=4EWKr7Ww_c0 and check it out. There's a few good comments about problems people are running into.

 

But that is still teathered jailbreak, with a MAC computer.  right?

4.2.1 for the Apple Tv is a tethered jailbreak no one as of right now has a untethered one fire Core has just come out with a app to help you whenever you to restart the apple tv.

http://support.firecore.com/entries/387605

hey did you get your apple tv 2g jailbreak