AppleTV 4k HDR10+ red video

AppleTV 4k (2022) has HDR10+ support.
HDR10+ works with the YouTube app.
Purchased Infuse Pro just to watch an HDR10+ file, but all I get is a totally red image that is flashing every second. Both my receiver and TV are showing HDR10+. When I disable HDR10+ support from Apple TV, it will automatically fall back to HDR10 and then everything looks as it should. Tried setting “Extended Dolby Vision” to “Auto” and “Off” in Infuse settings, that did not change anything.

Am I doing something wrong? Anyone else seen this?

Hmm. I just tried another file and that works perfectly.
Maybe a bug with first ones profile?

That would be my guess if you’re seeing another file play without problems.

It could be an issue with that specific file. If you’re able to upload a sample we can take a look.

Files up to 50GB can be submitted here.

I now checked more files. It seems that HDR10+ Profile A files play nicely, but with Profile B I get this terrible red video. Tried two different Profile B files with the same result.

Tried everything and I finally figured it out.
In my reicever settings I had to change the AppleTV HDMI input from “4K Enhanced” to “4K Standard”. And voilá, all different HDR10+ files now play perfectly.
Sorry for the confusion. Hope this helps someone in the future.


What kind of receiver do you have for those who may have a similar issue?

My first judgement was wrong. I actually had turned off “match frame rate”, which fixed it.
For some reason, if I have “match frame rate” turned ON something happens while the frame rate is being changed and the handshake between the receiver and the TV fails, which resulted in the crazy red image.
If I manually set the correct frame rate for the AppleTV (or the source matches the AppleTVs frame rate, so there is no “drop”) or if I have “match frame rate” set to off then I dont get the red HDR10+ video.
But obviously, this is not a solution, as the mismatch of frame rates can and does introduce judder.
Anyways as luck would have it, Onkyo pushed an update yesterday, which gets rid of the red video bug. But now my TV input info seems to constantly flicker between HDR and HDR10+ (only the info, the image itself does not flicker in any way).The previous holds true here, if I set “match frame rate” off or set AppleTVs frame rate the same as the source file, then my TV correctly shows and holds HDR10+ as input mode.
Anyways, as of right now, even when the TV reports as the signal is switching between HDR and HDR10+, I dont see any visual degradation and it (at least to my eyes) seems to be dynamic HDR.
Anyways, long story short, its an issues with the HDMI handshake failure that happens when signal changes due to frame rate matching. If I connect my AppleTV directly to the TV, it works perfectly, so the receiver in the middle seems to create the issue. Thanks to the latest Onkyo update, it seems to be fixed now, even though according to the TV info seems to permanently switching between HDR and HDR10+, the image looks identical to when I switch frame rate matching off and the TV correctly stays on HDR10+.

Anyways, Infuse does not seem to be the culprit here. Probably an issue between my receiver and TV.

Thanks for following up!

I suppose one thing to test would be to try and connect the Apple TV directly to the TV to see if this eliminates the issue. That would at least allow you to narrow down whether it’s related to the receiver or something else (like an HDMI cable).

I guess my post turned out to be a little
too long. As I said, I did connect the AppleTV directly and it did solve my issues. I did not say it, but I also tried a handful of combinations with different cables, both with and without the receiver in the chain to verify that the cables were not causing the issue (I am using 48Gbps HDMI cables).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.