Apple TV2 - XBMC Reboots

Dear All,

I am new here because i have a really strange problem running XBMC on my Apple TV2. Here is my info: I am running a jailbreaked (Seasonpass) Apple TV2 ios 5.0.2 (4250). I use XBMC Frodo 12.0 and everything has worked fine untill 6 days ago when my apple tv suddenly started to reboot every time i use XBMC. This was suddenly and not because of any updates etc. I then re-jailbreaked a couple of times with no luck fixing the issue. I tried without installing NitoTV and with but nothing worked. I have searched a lot and found suggestions to solutions but none has helped me. The really weird thing is that if i disconnect cable and use wireless then it works. And even weirder if i bring my apple TV to work then it works fine here with cable :slight_smile:

I would really appriciate any suggestions/solutions.

Thank you very much

Sound like you have power surge problem causing the apple tv, or your tv input acting weird.

:slight_smile: Ok thank you. What could be the solution then? Any thoughts?

Do you have a volt meter you can see what voltage from your electrical and from the work electric. Or you can get a power surge protector bar, to protect from eletric not grounding probably.

I tried a new power cord and a different outlet but problem still exists :frowning: But since it still works on wireless i do not think that the power is the issue. Maybe i should try the new 5.2 since i heard that XBMC is now supported?

Dear All,

Since XBMC now supports ios 5.2 i tried below solution to stop my apple tv from rebooting.

I restored my apple tv to original settings and in the process it updated to ios 5.2 as expected. Then i re-jailbreaked it using seasonpass and installed nitoTV in order to get XBMC running. However this did not work so i installed XBMC manually using ssh and after that i had no problems with reboot. Just wanted to let you all know. Thank you for your help.


Sadly to say my problem just reappeared yesterday :frowning: I am back to square!

Dear All,

After been driving me insane for weeks i tried so many different things that did not help untill i finally tried to change the DNS setting on the Apple TV. I changed it from automatic to manual and used Google Public DNS and entered this as DNS for Apple TV2. And so far no reboots. I am crossing everything i have that this will continue to work :slight_smile: