Apple TV won't 'start' after recent update

I recently updated my 2nd generation AppleTV via my Mac. Now it won’t ‘boot up’ successfully, it seems to get stuck in a cycle where it turns contantly restarts itself. I’ve tried holding menu and down, it reboots to the Apple screen but then return to this cycle of blue screen/black screen.

The light on the front is on the solid, a blinks off briefly once every 10 seconds.

John

I have exactly the same problem!

How can I restore the old version?

Michael

 

Did you update the Apple TV software or the aTV Flash (black) software?

The 2.0 aTV Flash (black) update requires Apple TV 4.4 or later.

I got the same problem with my Apple TV 2nd gen.

I should read what James wrote because I had 4,3 (I think) version and tried to apply the last FireCore update (I never did any update since I jailbreaked it in october 2011).

After the update, ATV is not able to boot up. I tried restoring ATV to factory settings with iTunes unsuccessfully. It said “Error 9”. I tried many times with 2 different micro usb cables. It doesn’t work. Tried Jailbreak it with Seasonpass without succes.

Did I broke my Apple TV?! I can’t believe I broke it with a simple update… Please help.

I just had the same problem.  All was fine, until I selected UPDATE ALL.  

The after attaching the cable and using Seas0nPass to restart, it stays in a loop trying to restart.

I get “no signal” on my LCD for 5 seconds, followed by 5 seconds of :HDI 720p 60 Hz", then just “HDMI” and then blank.  It then goes back and does this over and over.

I’ve powered down, and tried again.  No luck.  My ATV is a paperweight.

 

 

Did you run an ‘Update All’ through nitoTV by chance? Doing that is not recommended as it doesn’t discriminate and will install the latest versions of everything, even if they’re not compatible with your Apple TV version.

Your best option will probably be to re-jailbreak with the current version of Seas0nPass which will install the 5.0.2 version on your Apple TV.

This did the trick; thanks!!!