Apple TV Wont Power on TV

This has been bugging me for a while however its hardly the end of the world but I thought I might post here to ask the question.

In our daughters play room I have an old Panasonic TV TX-42A400B, there isn’t a whole deal of info online about it. Work sold it to me for very little so I snapped it up, good TV for a play room to be honest with kids around!

Anyway, the Apple TV wont turn it on, I have checked CEC and thats all on and enabled power control on the TV, all the stuff on the Apple TV is set right also, the Apple TV will turn it off but just wont turn it on. Ive been trawling the internet for yonks to try and maybe find a firmware update for it but coming up with nothing.

Its one of those annoying reasons why Apple should allow powering on TV’s via the IR part of the remote and not ‘just’ rely on CEC, because I just grab the TV’s own remote and power it on then use the Apple TV remote for the rest, there’s no reason why Apple wont allow that but its only volume you can get it to learn and not power, at least that seems that way to me.

Anyone have anything new I might not have tried or thought of?

Try disconnecting everything from power and then reconnecting it one by one.

Have you replaced the HDMI cable?

Also try a different HDMI port on the TV?

Yeah, tried that a while ago, keep the suggestions coming though, hopefully I haven’t tried something!

Yeah it’s not the cable and pretty sure I changed the port a while back to test but I’ll give it another whirl just in case. Thanks NC.

1 Like

Some TVs only allow a single, specific HDMI port be used with CEC features, so check the manual or labels on the back of the TV.

Yeah I’m gonna try it today when my daughters napping, I’m alone today so not going to start taking TV’s off walls with a 2yo around :slight_smile:

Curiously the power off function all works though on HDMI 1, there’s only one other port to try.

So I changed both HDMI port and cable and there was no change, the Apple TV happily turns off the TV but will not power it on, tbh I expect the Apple TV is doing its part just the TV’s CEC protocol or software part somewhere is too old. I might ping Panasonic a ticket and see if they have a firmware update for it that was ever released.

Strange thing about this TV is that its not a smart TV, has no smart functions at all but has ethernet and will grab DHCP settings from my router, what the port could be used for however I dont know.

No guts, no glory! You need to have something cooking in the oven too to complete the apocalypse. :clown_face:

Looking through the manual for that TV I think the clue is in the wording. For CEC link they list the section as “Power off Link” and describe it as

" When set to [On], all HDMI connected equipment will be turned off automatically by turning off the TV"

There is no reference to "turning ON the TV’

I’m guessing that you need to buy your two year old a new 75" OLED and accompanying home theater receiver. :wink:

Sorry we didn’t have a easy quick solution. :+1:

Yeah, I’ve suspected the same to be honest……

Well you mention a new TV, the plan has always been to put my existing 55” LG OLED in the play area when I refresh the main lounge tele, kinda overkill for kids but saves me getting upset selling my pride and joy :slight_smile: The issue will be solved then.

I did a ton more research on her nap actually and found that it’s from like 2014 this tele and I located a firmware update from 2015, never know it’s worth a punt I guess, old fashioned USB side loading on the cards tonight!

That’s for pouring through the manual dude.

1 Like

At least it’s a better remote than my parents had. Their remote controlled ALL the functions.

Hey NC, turn on the TV, it’s news time…

Hey NC, change the channel…

Hey NC, turn it up some…

Hey NC, wiggle the rabbit ears…




Plot thickens, I guess…

So I followed the steps to get it installed which I found…

I assume there is some automatic process when you insert the USB into the TV but it was doing jack…it doesnt say you are supposed to go to some menu and instigate it. I trawled the manual for the TV again and it shows it only supports USB 2.0 and my stick are 3.0, AFAIK though USB 3.0 sticks should support USB 2.0 ports. I dunno…I found it curious however that whilst USB 3.0 came out in 2008 this TV came out some 6 years later…and that if the manual is suggesting 2.0 is the supported type then maybe thats for a reason.

So currently im searching around my attic tryna find some old crap…IE USB 2.0 :slight_smile:

I’d guess it’s not the USB 3/2 issue, but more likely the formatting of the flash drive. The older set may require a FAT 32 format or NTFS, lots of older devices I’ve messed with wouldn’t handle the exFAT format at all or the APFS.

Yeah I tried NTFS and FAT32, the manual mentions it supports both, of course I’d never bother with any MAC format. Also tried MBR and GPT favouring the former I expect.

I’ll give the USB 2.0 a go later once the Premier League games finish, if it doesn’t work I’ll probably revisit it again in 6 months ha.

USB 2.0 stick used in the exact way the guide says doesnt work…I dont get it, you are supposed to power on the TV then plug the stick in and then the thing just pops up like an auto run…but nothing happens. Seems odd why you can’t initialise it yourself. Think ima just give up for now.

If you tried all these things…did you check in the APTV settings that allows your APTV to control your TV. it may be off.

Yeah thats totally on dude.