Apple Tv won't go DFU

Hey everyone, i just refreshed the ATv 2 OS and installed the latest and 5.3 both give the same results.
I have tried running the the OS after doing an update or reinstallation and then returning to JB.
I have tried doing refresh of OS and then straight into JB with season pass,
both ways when it says to press menu and play button give me no lights then after 7 seconds fast blinking. I let go and nothing. Will not goto DFU. Ideas?

Never mind, the fix was written in a another post.
Connect to laptop with usb and power cord to apple tv.
Press buttons for DFU and once Seasonpass finds DFU mode, remove power cord :slight_smile:

Never had to do it before now I’m curious why its needed.

I’ve had some that required power cord and some that didn’t… I think it’s either a finicky ATV or a USB port not putting out enough power.

yeah sometimes it needs a “jump” here is a good video showing how to jb easily

This is how I do a surefire DFU evertime. Find your silver remote before starting.

Step 1. Unplug all cords from aTV2

Step 2. Plug in the micro USB into your host & aTV2

Step 3. Plug in the power to the aTV

Step 4. Immediately once the power is plugged in aTV hold the play & pause buttons until the light flash quickly on the front of the aTV2

Step 5. Jailbreak via SP

Step 6. Once the jailbreak is done DO NOT UNPLUG THE POWER FORM aTV! Remove the micro USB and hook to TV via HDMI and go thru the menu to boot it the aTV properly.

Step 7. Finish all remaining setup/apps/etc and enjoy