Apple TV + Time Capsule Issue

I’ve got an Apple tv 4 running infuse 6. I’ve got 4 wireless Time Capsule Hard Drives that I add as directories, a 1 GB, two 2 GB and a 3 GB. Right now I’m unable to use the 3 GB HD because when I plug it in, it appears instead of one of the other HD’s. No Issue when it’s not plugged in. I’ve looked at their IP addresses in airport and they’re all different. I’ve tried forgetting the HD’s and adding them again in the infuse settings, but no luck.

Has anyone had this issue before and solved the problem? Any advice would be great! Thanks.

Welcome to the forum!

A little clarification would help. Do you have 4 different Time Capsules each with a hard drive internal, 4 USB hard drives connected to one Time Capsule, or 4 wireless hard drives linked to your Time Capsule? Or something totally different?

Also, you say

Appears where? In Infuse settings under Shares on the Saved Shares, Available Shares, or somewhere else?

If you plug in the 3TB (I’m assuming you meant Terabyte and not Gigabyte for all drive sizes) first and then the others do they take the place of the 3TB drive?

Yes, thank you for the reply. I have 4 external Time Capsules each connected wirelessly as Shares. When I plug in the 3 TB time capsule it appears to take the place of one of the saved shares for the one other drive. Always the same one.

It happens regardless of if I plug it in first or last.

Do you see all 4 separate TCs in the Available Shares?

Also, what protocol are you connecting with? SMB, FTP, DLNA, etc?