Apple TV - Qnap TVS872 XT - speed problem

For some reason when I test the speed from Infuse on Apple TV 4k to NAS it tops at around 90 mbps so my videos keep stopping and buffering, it makes it impossible to watch. The same happens if I tried to do it via iPhone (not sure how to test the speed there, though).
As if the WiFi speed was set to 100 mbps.
This however is not true as I used a speed test on a laptop from the same location, and I get upper 300mbps. Also tested a wired connection and get 100 MegaBytes/s write/read.
I have also tested Internet speed from Apple TV, and it is in upper 300 mbps. Any ideas what might be choking the connection? It is strictly related to Infuse on Apple devices and NAS.

My equipment:
TVS872 XT NAS - Orbi ax6000 - wired connection
Apple TV 4k - Orbi ax6000 - wifi connection
Orbi ax6000 - wired backhaul

WiFi test to NAS from a laptop
SpeedTest_fromLaptop_WiFi

Wired connection test to NAS from a laptop
SpeedTest_fromLaptop

Welcome to the forum!

Do you still get the stopping and buffering when you connect the ATV with Ethernet?

1 Like

Thank you.

I don’t know, ordered a 75ft. cat6 cable which I am supposed to get today to test it out.
It is really awkward that Apple TV can reach max WiFi speeds for the Internet, but not for NAS.
At first I suspected something was wrong with NAS, but as shown above, speed test to it over WiFI through some other device works at max speed.

It still could be WiFi related, you may want to see if there is an option to give a priority to a streaming device in your router settings. That may help also.

There are settings in Infuse that may help also. What protocol are you using to connect from Infuse to your NAS? SMB, FTP, DLNA, etc

Not sure, I wasn’t able to find anything in Orbi AX6000 that would allow streams to be prioritized.
I do have an update, though. Thank you for suggestion. So far I’ve been using Samba, but moved to DLNA, and the speeds are much better now, and the stream works without stuttering and buffering.
Curious to know what might be wrong with SMB, but as long as something works fine I won’t complain.

Thanks for all the support and quick responses.

Personally I’d not use DLNA since that disables many of the features that Infuse offers. I’d stay with SMB but try changing from “Auto” to “2” or “Legacy”

I have manually set protocols to Legacy, SMB2 and SMB3, and they were all pretty much the same, running at 80 mbps on average. DLNA runs on 260mbps on average.
Let me try to find some Samba test software and see if it behaves the same from other devices.

If your NAS supports FTP shares, try it, performance is much better than SMB shared.

1 Like

It does. I get the same speed as with DLNA, but it starts somewhat faster. I’ll probably pick it as my protocol of choice, thank you.

FTP is fastest on ATV/infuse, SMB/NFS is very slow vs FTP for me ~250 vs 800.

1 Like

Yes, I am sticking to FTP.
These 800 are over the wire, right?

Yes yes.