Apple TV install Successful but then nothing happens

I created the usb drive and ran the install successfully on the apple tv. It said at the lower left corner something like: “installation complete, reboot appletv…” or something to that effect.

AFter that, the apple tv reboots but it is the same screen as always. There is no option to run smart installer under settings or anywhere else.

Any ideas? I have the latest software on the apple tv and created teh patchstick on mac snow leopard


Has anyone had any luck contacting support? I tried submitting a request for support directly from their site. Nothing. This Forum, Nothing. Tried the phone number listed on their site and nothing.

I can’t get this thing to work. Pretty disappointed with this company and product so far.

To help troubleshoot your issue can you double-check the AppleTV and aTV Flash version your currently have installed?

The AppleTV version can be seen in Settings > General > About.

The aTV Flash version can be seen in Maintenance > About.