Apple TV Infuse & Weird Library Connection Problem (FTP v.s. DLNA)

I searched previous posts but I could not find a matching solution regarding to my problem. That’s why I had to open a post in here.

I have bought Apple TV 4K recently to connect all my movie archive located in my external disk via Infuse app.

I have a ZTE router which has ability to create an FTP server and DMS (DLNA) server to share my external disk over the LAN which is connected to its USB 3.0 port.

When I create an FTP server and connect it through the Infuse app, all the metadata (movie infos and cover arts) downloaded automatically, however maximum speed that I can have with FTP connection is approx. 2Mbit/s which is disaster. I cannot watch anything.

If I choose to connect DLNA server, I can have 70mbit/s speed which is acceptable for me and for my movie archive. But, with this method as far as I searched it is not possible for Infuse to create a library. So, I can’t have any metadata with this.

I tried to connect both FTP server and DLNA server at the same time. So that, I could have both metadata for my archive and enough speed to play movies. However when I clicked on a movie poster through the library Infuse plays it over FTP connection, which means it can’t play.

Currently, I am browsing the movie through the FTP library, but when I decide to play a movie, I browse the DLNA folder and play it.

Is there anyone who can suggest me a solution for this problem?

PS: Router and Apple TV is connected each other with a CAT5E Lan cable. I know CAT6 would be better, but I don’t think this is reason of very slow speed.

Either get a new router or invest in a NAS. Its your router that’s the bottle neck here.

Thank you for your reply. Since, I will just use this device as an USB host, investing in a NAS is not fo feasible from my side. I also have to use this router because of my ISS. Maybe I will get another router to use it only for USB sharing.
But to be able to fully understand you, could you please clarify that same device (my current router) can host higher speeds with DLNA but slower with FTP. Is this possible? I read some posts on this forum indicating that users can reach maximum read speeds with FTP connection rather than other methods like DLNA, SMB, NFS, etc. If it is true, I have to buy a new router as you suggested or I will change my Apple TV with a simple android box with USB port which can run an app like Infuse.

How are you connected from the ATV to the router? If wireless you may want to test it with an Ethernet cable and see if that helps. Also, are your only two choices FTP or DLNA? If you can configure an SMB connection that may be faster with your equipment. FTP is not always the fastest protocol. For some it is but others have better luck wth SMB.

Your router may have a priority setting which is keeping the ftp connection at a lower speed and it is giving priority to streaming connections. Maybe post the model number of your router .

Where did you get the speeds from? Are you looking in the Infuse settings under the shares or some other method?

Thanks for the reply. As I mentioned in the first post, router and Apple TV 4K is connected via CAT 5E Lan cable. And yes, I have these speeds from Infuse app under shares section.

I have also tried disabling all other services and enabled only FTP but no luck. Result was same.

My router is ZTE H267 there is no so much information about it on the internet. Attached you can see a screenshot of supported services belong to router homepage.

As you can see SMB is also seems available but I could never establish a connection with SMB beacuse of the SMB version of my router. I tried all options in Infuse while trying to connect (SMB v1, v2, v3, auto, legacy) I even could not connect to my router via my macbook over smb. MacOS says that SMB version is incompatible.

First, just to make sure I’m understanding things correctly. You are connecting your hard drive to the router correct?

Assuming you are…

Don’t see a screenshot yet, but it does appear that your router does have a QoS setting so you may want to try turning it off and see if that improves your FTP speeds. QoSGlobalConfiguration https://setuprouter.com/router/zte/zxhn-h267n/qos-73347-large.htm

This would be my guess.

Somewhere in the router settings there should be some place to set up user and password security for connecting to the USB drives. It also may be a “Public folder” situation so you may have to set up the folder where your videos are in a specific order.

Sorry for the missing attachments. I attached a few screenshots for your information.

I checked the link you shared about QoS but my router does not have that section available. I couldn’t find a place for user credentials for USB either.

As previous it could be the router isn’t really optimized for file transfers and just offers it as a convenient “after thought” feature. Have you tried hosting the drive from your MacBook?

Yes, I shared my external disk via SMB from my MacBook over WiFi and result was the best (100Mbps) compared to router speeds.

It seems I am a little bit unlucky beacuse of the router limitations.

SMB: Seems available in router but SMB version is either too old or something wrong with it. Because none of the clients (infuse or Macbook) cannot connect it.

DLNA: Works very well but because of the DLNA itself, Infuse app cannot create a metadata library.

FTP: Infuse can create metadata library, however data transmission speed is 2Mbps.

Thats why I should find another device which will be able to broadcast very well. NAS will be the most expensive option so I eliminate it.

Do you suggest having a new router with those functions or something like WD MY Cloud Home with Gigabit Ethernet Port?

I’d definatly avoid the MyCloud Home. It’s proven to be a nightmare for many. Have you asked your provider for assistance in setting up a SMB shared disk?

I still think there are some settings on your current router that is causing the problem. Maybe request a “complete” manual from your provider?

Unfortunately there is no other setting which can solve this problem. I contacted to my internet provider but they don’t have any clue what I am asking for, of course.

It seems WD is also eliminated. So, I am waiting for the best router suggestion which can work “very well” with Infuse app.

Optionally you’re could also just buy an odroid n2, throw librelec on it and connect your drive to that.