Apple TV in DFU mode but iFaith fails

I have been at this for several hours now and I am at my wits end. :(

I have a virgin apple tv with 4.3.  I am trying to dump the SHSH using iFaith.  I have tried many combinations of the following.

4 different micro usb cables

3 different machines running iFaith

2 different versions of iFaith

DFU from usb only and DFU with power and usb cable


The end result is no matter what i try, iFaith says “you failed to enter DFU. Please try again”.  According to the usb status I have an apple TV in DFU mode, but iFaith refuses to see it.  Any ideas what I am missing?

Although I have nothing to offer, I too am in the same boat. I’ve tried everything with no love from iFaithless

Please post a remedy if you find one. I will certainly do the same.



So I think I have narrowed this down to USB port power issues. I would get to uploading iBEC and stall just as OP has described.

I took a hint from the post above and tried the power cord trick with no love but did not stop there. I thought what if I used a powered USB hub since I was getting power overload on USB port messages from windows.

The powered USB hub port gave me a different result but not as far into the iFaith process. So, I experimented.

I’m not sure exactly what I did since I was trying all sorts of combinations, but I think it was pulling the power to the USB port hub as iBEC was loading. Like magic, worked and i got my 4.3 shsh blobs.

All I can suugest here is to try all sorts of combinations until something works for you.

Hope this is helpful.


Someone mentioned in my iFaith thread that they reset the Apple TV in the menus and that helped. In either case it seems like iFaith is buggy and dumping blobs is quite a PITA.

How do you do that? My ATV is basically dead.

Just starting to use sn0wbreeze to JB. So far so good.

Are you able to JB 4.30?  I have a 4.30 and I can dump its SHSH blobs no problem. However, after I used snowbreeze to stitch it to a SPSW.

I will always get 16xx error in iTune during restore.

Totally wasted the day on this. Although I FINALLY dumped blobs, I cannot for the life of me get this frikkin iOS to JB…

Windoze is such a waste of time…wish there was an OSX version of Sn0wbreeze.

Ive downgraded iTunes, rebooted a thousand times, checked host files, powered and unpowered my USB hub, different cables but there is no way this is going to jailbreak.


I am over 40+ hours into this and I am tired. I have decided to just upgrade to 5.2.1 and wait for the untethered jailbreak. Thanks to all for your help.

iFaith 1.5.5 doesnot work for 4.x. I used iFailed 1.4.1 and I can dump the blob for me 4.30.

That’s good to know.

I have another ATV to get blobs from but it’s already on 5.2

I’ll try my 4.3 ATV tonight and confirm this.


i said this before in another thread and it has now worked for me 6 different atv2’s that i couldn’t get blobs from.

just plug your atv into your tv restart it fresh go to settings and reset them.  put it in dfu mode again and try ifaith again.  it will work.

yes there are some issues with ifaith but this resolves them.

6 times tested 6 times working.


Can’t find a working v 1.4.x of iFaith

Where would one find such a beast? I tried my other ATV with 1.5.6 and that sucker just doesn’t work again.

I guess I got lucky the first time


During my marathon, I did reset and use 1.4.  No luck.

@biggietx  try it with the latest ifaith right after reset and keep the power cable in rather than just the usb cable.



Do you mean to use “iREB” to DFU mode before launching iFAITH?  In my case, iFAITH will prompt you to put apple tv in DFU mode when I try to dump SHSH blobs.  The process stuck at the upload phase.

Just replied to another related post to this:


If you are trying to do the dump using a laptop, try using a windows desktop instead.  I used ifaith 1.5.6 and it has worked for me each time now from a desktop system.  

hope this helps!