Apple TV in 2.3 help!

Hi All…

I had an AppleTV that had 1.1 update by my uncle by mistake to 2.3… How can I flash it now with ATVFlash software? I create the Patchstick but when I connect it to the AppleTV and turn it on, nothing happen…

I had been browsing the forums before posting this, please, if I didn’t finf this and it has been mentioned before, don’t bash me… Please help!

What can I do?

Best regards,


You followed all the steps right? You made sure the AppleTV 2.3 DMG was mounted when you ran the aTV Flash application? Also be sure you ran aTV Flash from the DMG and did not move the aTV Flash application outside the DMG? Did you erase the flash drive before running the patch? This is what I posted elsewhere:

OK. I think the problem is when I create the USB stick. I’m using a Kingston DataTraveler 256mb that I’ve used before with the same AppleTV. Problem is when I run ATV Flash and select it from the list, after it creates the partition and I select everything (nitotv, boxee, etc) from the list, it takes 2 seconds and then it says that the USB has been created successfully. In the manual it says that this could take up to 5 minutes…

What can be wrong?


P.S. Thanks all for your help!

You might need a bigger flash drive, it’s possible that you might need a 512MB at a minimum. I use the original 512MB iPod Shuffle, the white one, and it works fine.

OK… I just did it with a 1GB USB Flash drive and the same thing happens. It takes at the most 5 seconds until it tells me that the usb has been created successfully… I do have the OSBoot drive mounted and I’m running ATV Flash from the Desktop…

Any other ideas?



It sounds like the files are being copied to a folder on your computer instead of the flash drive.

  1. In the Finder ‘Go’ menu, select ‘Go to Folder’

  2. Enter ‘/Volumes/’

  3. If you see a folder named patchstick-root, or something similar, remove it.

  4. Run through the installation process again.

OK. Here’s what I do:
1- Insert the USB stick. Erase it as you explained in your post, basically do it twice…
2- Mount the correct OSBoot image, downloaded from your post too…
3- I d/l again, just in case, ATV Flash 3.4.2
4- I have the OSBoot mounted… In Finder, Go, Go to Folder, I see: “Macintosh HD”, “OSBoot” and “Untitled” (which is the usb drive)…
5- I run ATV Flash from the desktop and I’m ready to unlock the magic.
6- I select “/dev/disk1” Untitled from the list, which is the usb drive…
7- I click start and choose “OK” (to erase everything).
8- I wait 5 secs (aprox) for the usb to be partitioned and then get the check list…
9- I check everything on the list (I’ve also done it checking only the top portion of the list, not the advanced list)…
10- I click ok and then see the progress bar “fly” from 0 to 25% to 100% in 3-4 seconds and get a message that the Flash Drive has been successfully created… NOT… jeje

Anyway, I am open to suggestions again and thanks for your help…


P.S. You might want to move this thread to the “USB Flash Creation” one …

Just to be sure, did you try out aTV Flash’s recommendation about seeing if there is folder called “patchstick-root” in the Volumes folder? Be sure that you have the USB drive unplugged so that your computer does not mount that drive. If you see a folder called something like “patchstick-root” then delete it. If you do not see a folder called that then I’ll have to get back to you about a possible solution.

Yeap, that was setp 4 above!



Have you run all the Software Updates on your Mac? I believe aTV Flash uses Java and you should have the latest Java version for either 10.4.11 or 10.5.5.


Mac is up-to-date… Just tried again and same thing happens. After creating the Patchstick partition and checking the apps to install, it takes 5-8 seconds after I get the finished message.

I really appreciate you trying to help! By the way, I’ve tried this on two different u-to-date macs…


Are you running the installer directly from the downloaded disk image, or has it been copied to the computer first? The application should be ran directly from the downloaded disk image.

atvFlash, I think this was the problem…

I’ll let you know later…

Thanks to you all!!!

You know, you think I would have made this suggestion. I just went right passed it. :frowning: :wink:

I too cannot get atv to install atv flash from a successfully created patchstick.
Each power down and repowering up of my atv just yields the same old software.
I’ve recreated the patchstick twice and followed madcran’s os boot instructions.

Why is it not installing on the atv?

What flash drive are you using?

It’s a drive given to me by an Epson rep that is 4 ghz…

The patchstick that I made seems to have all the necessary folders.
Contents, System,, BootLogo.png,boot.efi (which is locked?), mach_kernal,
I think its successful?

You shouldn’t be able to see the patch after it is created. One of the final steps is that the partition is not mountable. After the aTV Flash application finishes I get a message that a drive is not readable, Do I want to Erase, Ignore, Eject. Don’t you get that message, where are you looking at the contents of the flash drive?

I am getting the same results. I create the patchstick and it seems to be ok. I dont get the error message at the end about being unreadable just an eject option. After creating the patchstick I am bale to browse all the file on it. I plug it into the ATV to flash and nothing happens. i recieve the apple logo, blinks three times and does nothing. Just goes to the default apple OS.

Please Help, would like to get ATV flashed