Apple TV Gen 2 Keeps Rebooting after nitoTV/xbmc upgrade

I loaded up my apple TV 2 and went into XBMC and noticed that naviX kept crashing not common. so i went to the home page of apple tv 2 and went into nitoTV. I clicked on ‘upgrade all’ and now its in a perpetual reboot loop. I was able to ssh into the appleTV using putty but i didnt change anything. help me please. oh and im running on iOS 4.4.4

Try this:


for me, I have to do this every few weeks for some reason.


I have the same problem and that worked for me. If the problem insists I will do it again. Thank you.

it doesnt work this is what happens

i was forced to do a restore. I opened up itunes hit restore, downloaded the newest seas0n pass and re-jailbreaked it. 

I have the same problem and I am getting the same error if I wonna remove beigelist “the list of sources can not be read”

Has anyone another idea? I really would love to avoid re-jailbraking.

Maybe I could overwrite it manually if someone sends me this file list /etc/apt/sources.list.d/saurik.list ?


P.s. if there is no other way around, what folders do I need to backup to keep my atv settings aswell as my xbmc settings?

thank you


 I deleted saurik.list  with over ftp and hit the commend apt-get install --reinstall beigelist com.nito.nitotv .

Now I can boot into ATV but the GUI is not reacting anymore :-/

Same thing happens with apt-get remove beigelist 

apt-get install beigelist com.nito.nitotv org.xbmc.xbmc-atv2

booting up fine but ATV is not reacting to my remote :frowning:

you’re going to have to re-jail break it. Load up itunes, hook up you ATV2 factory restore, download latest jailbreak and you’re good :) 

will this delete all my settings? if yes, what do i need to back up?  what folder in ATV itself and what folder in XBMC ?


thank you



Unfortunately you will lose all your settings, you will have to reinstall everything. However a working ATV2 is better than a broken one. I had to rejailbreak it in order to get it working again. So ya…

Have you tried unpairing the remote?

hurray, it works again, with the remote re-pairing. no re-hacking needed :smiley: